Sharpen AI crashes

When I open a photo in AI Sharpen the progress indicator freezes at 2% for several seconds, more that 30. It has stopped working completely when applying a mask or saving photos on several instances.

Dell XPS 8910
Windows 10, latest upgrades
32 gig memory
Intel i7 Processor
NVIDIA 1050 Ti w/4GB

1 Like

Which version is that?

Please open Sharpen AI, go to Help-> Graphics info and press Copy then post the info here.

The freeze at 2% sounds like it is loading the model. The initial load usually takes a while as it has to unpack and load all the AI data.

If you are crashing, do you have steps to reproduce it? Does it only happen on certain images, or do all images crash when doing certain steps? You can also try changing your processing mode in the advanced section of preferences and see if this alleviates some crashing.

I don’t know about mfw1948-84871, but I have a similar problem. Yeah, I get a freeze for a while at 1 or 2% (I’m running v2.1.5, but previous versions did it too). Unpacking would explain the pause. However, there is another issue that follows: When the progress counter gets to 100%, the plugin closes, but doesn’t return control to the host program (in my case PaintShop Pro 2020). The only solution is to kill the PaintShop process, and lose all the work I’ve been doing. If I don’t kill the process, it will hang indefinitely. This happens maybe 30% of the time.
Additionally, since upgrading to 2.1.5, I’m repeatedly told there’s an upgrade available, but the “upgrade” is 2.1.0. What gives?

The upgrade is v2.1.7 … See

With PSP are you calling it as an external editor with Sharpen AI not open at the time?

If I understand you correctly, then yes. I open Sharpen AI as a plugin from PSP.

Your answer that the upgrade is 2.1.7 is followed by a block showing 2.1.0. That’s just what happens if you click the release notes link too.

EDIT: I see now that the link points to 2.1.7, though it still says 2.1.0.

It’s the 2.1.x series, the release notes in the first post show 2.1.7 as the last dot release.

It would be less confusing (and I have been confused by this) if Topaz marks the latest release download link as 2.1.x instead of 2.1.0 .


I feel we’ve strayed off this topic a little, as we were actually discussing crashes. I have the update installed and the problem persists as it did with previous versions. It seems to be sufficient cause for failure that I should happen to want to do something other than watch the progress counter while the image is being processed. As soon as Sharpen AI is no longer the focus (if you’ll pardon the expression), it fails to return control to PSP.

You still haven’t posted the details from Graphics info, and also post a screenshot of the preferences with Advanced showing.

If you are using GPU make sure there is enough memory available, advanced preferences notes:


No, but in my defence, it wasn’t me that you asked. :slight_smile:
Since you’re interested, my graphics info looks like this:

Application & Version: Topaz Sharpen AI Version 2.1.7
Operating System: Windows 10 (10.0)
Graphics Hardware: GeForce 940MX/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 376.54
CPU RAM: 8060 MB
Video RAM: 2048 MB
Preview Limit: 4335 Pixels

And the preferences look like this:

Any thoughts would be appreciated.

Update your GPU drivers from the NVIDIA website, they are way out of date as the current version is 456.38 and that should help.

Well, that was weird. Nvidia always said there were no updates available for my card, but I found the version you described and it installed just fine. I’ll let you know if it helps. :slight_smile:
Thanks a lot for the suggestion.

I now have:
OpenGL Driver: 3.3.0 NVIDIA 456.38

1 Like

So… I’ve been playing with this since yesterday and I can tell you the following:
Processing is actually much slower than it was.
Preview updates are much faster than they were.
So far, the program hasn’t once crashed or failed to return control to PSP.
I’d say the increased processing time is a small price to pay given that I can tinker with the settings and get rapid previews before choosing to process the image, and that the thing actually works in the end. So, all in all, a good move. Thanks for the advice.

Hello Don,
Sorry for jumping in here but I have an issue with Sharpen crashing. It seems to run well (after system recovery and starting everything out fresh) then it starts to crash. Have it at low settings and CPU at Low makes it way too slow and on Card it crashes. Keep temp files cleaned and other programs closed.
Has been running fine (last two weeks or so) now crashing again, I always keep it on Low:

Application & Version: Topaz Sharpen AI Version 3.3.1
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce RTX 3060/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 471.41
CPU RAM: 16150 MB
Video RAM: 12288 MB
Preview Limit: 8000 Pixels

I just restored to earlier date so going to check it now. Ok says: “Auto settings model missing or corrupted”.

Have deleted previous files and used new from this forum and still same result.

Hi, have you tried updating your GPU driver to the latest Studio version, v472.47, and see if that helps. Make sure you use medium settings for the GPU and that it is selected rather than Auto.

Hello Don,

Ok, so update here. PC was sent to HP in Tx. They replaced the GPU and ran tests. This PC is only about 90 days old ordered from and shipped by HP. I still had the same problems with the SAI, DAI and sometimes GAI with the slowness and crashing.
I reached out to Topaz support and sent them the file logs to document the event. They have told me that I needs quite a bit more. So I am confused at this point. Are the specs of this PC not performing as designed? The PC also seems to be very slow at opening the files from GAI so I am wondering if this is typical or if it is a related issue with the PC.

Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce RTX 3060/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 472.47
CPU RAM: 16150 MB
Video RAM: 12288 MB
Preview Limit: 8000 Pixels

Please advise :slight_smile:


The PC is well specked according to the Topaz Labs technical requirements, for the logs just make sure that logging is turned on in the Help menu … there is also a link there to open the file location.

Also make sure the GPU selected in the performance section, note that the drivers are out of date and they can be updated from the NVIDIA website. Note also I would set the GPU vRAM settings to be at least “medium” not “lowl.

For the image you are trying to process what type is it, i.e RAW or TIF etc, and what are the physical dimensions of the image?

Well my own experience with Topaz Ai crashing when the other topaz products worked just fine. After extensive trouble shooting (driver updates) reboot, uninstalls. I got things working again by reseting my Asus GPU tweak to default. I then uninstalled my microsoft visual c++2015 install. I went to the microsoft site and installed microsoft visual c++ 2015 both x64 and x86 (14.0.2306). Seems ok now but then it could be malware or something that requires more attention like regedit. I’ll post again if things change.

things were fine until i installed this?
it could have been the visual c++v56.exe ??? if it ant broke dont fix it. :slight_smile: