Sharpen AI became very, very slow

Since my upgrade to Sharpen AI v.3.0.3 the ‘update preview’ and ‘save image’ function became very, very slow: it takes more then 20 minutes to update a preview and it takes almost 1 hour to save a image!
How to solve this problem?

1 Like

Please open the application and then choose Graphics info from the Help menu, press Copy and paste the info here.

I have the same issue, it just hangs at the processing stage. It is a plug in to PS. Sometimes it just exits to PS without applying the changes. My graphics info i here

Application & Version: Topaz Sharpen AI Version 3.0.3

Operating System: macOS High Sierra (10.13)

Graphics Hardware: AMD Radeon HD - FirePro D500 OpenGL Engine

OpenGL Driver: 4.1 ATI-1.68.20

CPU RAM: 32768 MB

Video RAM: 2047 MB

Preview Limit: 4492 Pixels

And it takes around 10 minutes for the processing to complete

You will need to raise a support request at the main website as this seems strange.

Application & Version: Topaz Sharpen AI Version 3.0.3

Operating System: Windows 10 Version 2004

Graphics Hardware: Intel® HD Graphics 2500

OpenGL Driver: 3.3.0 - Build 10.18.10.4358

CPU RAM: 8075 MB

Video RAM: 1500 MB

Preview Limit: 2765 Pixels

I have the same problem - Sharpen AI v,3,0,3 is VERY slow. Here is my information:

Application & Version: Topaz Sharpen AI Version 3.0.3

Operating System: macOS 10.16

Graphics Hardware: NVIDIA GeForce GT 750M OpenGL Engine

OpenGL Driver: 4.1 NVIDIA-16.0.13

CPU RAM: 16384 MB

Video RAM: 2047 MB

Preview Limit: 4492 Pixels

Your hardware is simply to slow, do you have an alternative GPU? If not you can revert to the previous version from the product release section on this

In your case you will need to raise a support request at the main website.

Thanks!

Thanks for your quick reply. I will try a more efficient GPU.

I also have the same problem. My graphics info is:
Application & Version: Topaz Sharpen AI Version 3.0.3

Operating System: Windows 10 Version 2009

Graphics Hardware: Radeon RX Vega M GL Graphics

OpenGL Driver: 3.3.13521 Core Profile Forward-Compatible Context 24.20.11001.8003

CPU RAM: 16195 MB

Video RAM: 4096 MB

Preview Limit: 7102 Pixels

Will this support the Version 3?

Please raise a support request at the main website. Although Intel says " The performance of the Vega M GL should be between the Nvidia GeForce GTX 1050 and 1050 Ti according to benchmarks from Intel." it seems it is specific to Dell PCs and needs other settings.

I want to revert to the previous version but I don’t know how todo it.
Can you gve me some instructions?
Thanks

As I posted above in this thread “… If not you can revert to the previous version from the product release section on this website”

Thanks AiDon. I’ll raise the issue on the main website.

After the update to 3.0 Sharpen AI has gotten progressively problematic. The latest update 3.03 made the motion sharpen choice unusable. After a small mask the process has slowed to a crawl and by the time it’s done no sharpening has occurred. Using the out of focus and too soft options are slow but at least they work. As far as work flow goes I have to reset the mask function every time which has slowed my process down. I shoot mainly action shots in low light so occasional need a bit of motion sharpness. prior to the 3.03 update it was a lifesaver. Now I can’t use it at all. My drivers are all updated. If the software is going to outrun the capabilities of my machine it will be time for new software, not a new computer.

1 Like