Sharpen AI as a Photoshop Plugin bug

I believe I’ve discovered a bug in Sharpen AI. Here’s the scenario.

  1. I open an image in Photoshop from Lightroom
  2. In Photoshop, I created a layer as a Smart Object and open Topaz Studio.
  3. In Topaz Studio I apply AI Clear and save.
  4. Photoshop will then show Topaz Studio as the filter applied to the Smart Object.
  5. This worked perfectly until yesterday when I purchased Sharpen AI and installed the latest version 1.1.0
  6. Now when returning from Topaz Studio the filter as shown as “Sharpen AI” and when I click on it opens Sharpen AI when I only used Topaz Studio & AI Clear.

Sounds like a bug. Can anyone help?

Thanks,
…Jerry

I can reproduce this behavior.

1 Like

I made an action inside CC2019 - it was based on Topaz Studio - but! It too opened AI Sharpen, not Studio!

1 Like

Getting this over to the engineers who handled the plugin functionality. Sounds like something is getting stepped on. Thanks for bringing this to our attention!

2 Likes

I should have mentioned, I’m using the latest version of Photoshop CC - Adobe Photoshop Version: 20.0.4 20190227.r.76 2019/02/27: 1205725 x64.

…Jerry

This issue was raised nearly 2 weeks ago http://discuss.topazlabs.com/t/sharpenai-overwrites-in-ps-actions-that-use-topaz-studio/9755 if not earlier. Hopefully it will be addressed soon as I have to uninstall Sharpen AI to follow my normal workflow.

1 Like

You are right it is a known bug.

The ticket got mixed in with the influx of other Sharpen AI release / sale related tickets and didn’t get elevated to the devs. It has been now. I didn’t see the original thread, so thanks for re-linking.

All, feel free to tag me when posting things like this so it can filter up in my busy notification box. I unfortunately don’t get time to read all the threads. @AiDon already does a bang up job of letting me know about a lot of issues. I can only imagine if everyone did :wink:

1 Like

on macOS 10.13.3 and PS 20.0.4 same error

“I clicked on a PS Action, and instead of opening Topaz Studio, it opened Netflix!!!”

THANK YOU :slight_smile:

(…you know I’m yanking your chain…?!)

2 Likes

I have a similar problem - uninstalled A.I Sharpen - which was no easy task - but this didn’t solve the problem

Just for the record to know it was logged and acknowledged - I logged a ticket on this issue (from the original Thread) and did get a response that it was a known issue and waiting on a fix/update in the future. (#168242 & #169478)

Unfortunately this is a known issue that is in production. 

We are working on a fix for it. The fix will come as an update to Sharpen. Unfortunately there is nothing to do at this time except to wait on the fix. 

We are very sorry for the inconvenience.