Sharpen AI 2.0.4

I tried the mask function in v2.0.4 this morning and got the same crash on save mentioned above. The original was a 6.6 MB jpeg in sRGB format.

I installed and tried the just released version 2.0.5 with the same image that crashed before, and it seem to be working fine. Created a new mask, tried all 3 algorithms, exported the JPEG, and the output looks as it should. I’d say thank you Topaz Labs for the quick fix.

Today’s v2.0.5 update successfully resolved the crash on save issue.

Just did a complete uninstall of my Mac SHARPEN AI folder . . . installed the new V2.0.5 . . . tested the masking in both Standalone and C1P12 Edith With function . . . both appear to be working perfectly . . . no crashing and masking and sharpening as intended!
Good work by TOPAZ and TOPAZ Support on promptly rectifying the issue!
Best,
V G

I just installed the latest patch v2.0.5 and the relaunch issue seems to be fixed.

I face the same problem
Today I install v 2.1.0 and the programm crashes by using the mask modus (TiFF File)
I use Topaz Sharpen as LR Classic Plugin
Operating system WIN 10

Best regards

Ludwig Baum