Sharpen AI 2.0.4

I’m finding that Sharpen works as it should without any masking.
With a mask applied, the save as seems to complete, but the program then closes and no file is saved.

Application & Version: Topaz Sharpen AI Version 2.0.4

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 1050 Ti/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 442.19

CPU RAM: 16291 MB

Video RAM: 4096 MB

Preview Limit: 6170 Pixels

I’ve found on a help page that this is knows with 2.0.3 but has been fixed with 2.0.4.
I wasn’t aware of it in previous versions.

The edge aware brush is simply terrific.
I wish it was as accurate in Studio. For me neither 1 nor 2 have not been very accurate at the edges of masks.

I have the same experience. In addition the application hangs so it’s no longer possible to start it again.

Go to File-> Preferences and press Reset in the Advanced section. Then open an image, just use Auto or set any manual settings and it should Update, if manual Update is on use the Update button.

Make sure also that you press the Apply Mask button before saving.

1 Like

The reset in advanced section did not work for me. Crashes while saving file. On OS X 10.14.6.
Started to happen after i did the update to Sharpen 2.04. Pleas fix…I depend on this app heavily .
Thanks for your attention .

I have the same experience as Mcboy, but when I use Sharpen AI 2.0.4 without applying a mask it does not crasch, as soon as I applied a mask Scharpen AI 2.0.4 crashes when saving.

Is that after pressing the Apply Mask button before Save/Save As?

I can replicate that with the following system error:

Faulting application name: Topaz Sharpen AI.exe, version:, time stamp: 0x5e7e71a5
Faulting module name: ucrtbase.dll, version: 10.0.18362.387, time stamp: 0x4361b720
Exception code: 0xc0000409
Fault offset: 0x000000000006db8e
Faulting process id: 0x1050
Faulting application start time: 0x01d60677ae3e2004
Faulting application path: D:\Program Files\Topaz Labs LLC\Topaz Sharpen AI\Topaz Sharpen AI.exe
Faulting module path: C:\WINDOWS\System32\ucrtbase.dll

@adam.mains can you look at this please, you can find the Logs at this link:

Logs 0330

We currently have a build sent out to someone to test. Hopefully should be fixed today.

This is due to a rounding error on larger images which causes the mask and base image to be different sizes.

1 Like

I have the same thing going on!

Sharpen AI 2.0.4 does not save the result. The preview still works, but nothing happens when saving.
I have already uninstalled the program, reboot my laptop and reinstalled it.
With version 2.0.3 it still works, even if the programm crashes afterwards.
Is it possible to use version 2.0.3 (download)?

I had been using the trial version 1.4.6 of Topaz Sharpen AI on Widows 7 and was very impressed so I upgraded and bought version 2 When I installed it and tried to run it, it is stuck on the splash screen saying Topaz Sharpen AI (not responding).

Does anyone know what I have done wrong? BTW, version 1.4.6 still runs

I’m suffering the same as most of the previous posters - there is no saved file. I am importing CR2 raw files direct into version 2.0.4 from Lightroom. I have used manual and auto modes, in manual both focus and sharpen, with and without using the mask function - in all cases, the previews show what the outcome should be, but when asked to save as imported format and same file location, 3.5 - 4 mins later, nothing has been saved although it goes through the process on Sharpens screen. Shame I ditched the old version, although I do rate the masking functionality. 2.0.4 was downloaded this morning and updated with all notified updates. OS is Mac OS Catalina v. 10.15.4.

You cannot save as CR2 from any application except DPP. Try changing to TIF.

Software crash

Been reading other threads under this topic and I am having a similar problem which has been referred to technical support without a successful fix at this point so I thought I would mention it here…

Sharpen AI 2.0.4. keeps crashing after processing 8-10 images via Lightroom plugin.
I have tried reinstalling in accordance with Tech Support protocol to no avail.
Then tried suggestion of changing CPU settings turning on discrete GPU and turning off open VINO. (default was the other way around)
Then opened SharpenAI via Lightroom. It worked for 1 image then crashed again.
Tried opening as Standalone but it would not open.
My system is:
Windows 10 Pro 64 bit
HP Tower G5
Processor Intel Core i7 9700 CPU 3.00
Memory 16GB
NVIDIA GeForce graphics RTX2060

Given similar issues being experienced by others, is this simply a matter of waiting for Topaz labs to provide a fix via another version or is there something else I can try in the meantime please?


What type of image are you passing to Lightroom, e.g. TIF, PSD, JPG or PNG (and settings).

Please go the Help-> Graphics info, press Copy and then paste the info here.

Image type is RAW .ARW and .NEF file format from sony and Nikon cameras.
Not sure which settings you mean. If its LR settings, the system will not let me copy paste.
Interestingly, I could not open Sharpen AI Standalone after it crashed, however now, when answering your questions, I can now access it.

Application & Version: Topaz Sharpen AI Version 2.0.4

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce RTX 2060/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 431.98

Graphics info as follows:

CPU RAM: 16158 MB

Video RAM: 6144 MB

Preview Limit: 6441 Pixels

You cannot send RAW to Sharpen AI, it must be of the type TIF, JPG, PNG which will be generated by LR. What are you sending?

The files are definitely ARW and NEF files. As soon as you clickon the "Edit in Sharpen AI, it immediately creates a TIFF file.

1 Like

I have the same issue with the standalone version and JPEG. Hopefully the fix will be available soon.

I hope so too. I note that since switching over to the GPU for processing it is working very hard and wondering whether it overheats and has a cut out when it gets to a certain temperature to protect the PC.
I am not a technical person but perhaps someone on this forum might know.

Using Studio 2 AI filter as an interim response to Sharpen AI issues.

Further to the above discussion, I decided to try using Studio2 as an alternative plugin in Lightroom until the Sharpen AI issue is resolved. My processing is for bird photography and I must say, I have been pleasantly surprised. Using the AI Clear filter set at high for both Noise and Sharpness, the images produced are not that much different to Sharpen AI using the same settings. If anything, a bit more natural. My GPU is not working as hard and it is taking much less time to complete the process. I am using the High level because most of my recent photos were taken on a trip where light was atrocious resulting in lots of noise.
Hope this may assist others.