Selection Lag for RAW makes it unusable

System Specs: 2022 M1 MAX 64gb RAM

When trying to edit a selection the lag in movement of the image and brush makes the process unusable. I have deleted the entire application, rebooted and reinstalled it several times with no noticeable improvement.

Steps to reproduce issue:

  1. Plug-in Extras, Process with Topaz AI
  2. Sharpen “Subject Only”
  3. Edit subject

Using NEF files shot on D850


Topaz Photo AI [v1.x.x] on [Windows/Mac]

1 Like

I’m experiencing severe lag on selection editing as well, using NEF files from Z9.
(M2 Max, 32GB, Sonoma 14.4)

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.

Unfortunately, doing this didn’t change anything; editing a selection is still very laggy.

Please reach out to us at the following link:

Topaz Labs | Support Page

I just see a couple of articles on there that don’t address this. Is there supposed to be something else?

At the bottom right corner of the Support Page you should see a pop-up window that allows you to send in a support ticket to our team. You can also send in an email to us at help@topazlabs.com

This topic was automatically closed after 60 days. New replies are no longer allowed.