Remove tool



The remove tool has a problem replacing the workmen/lift in this image.
affinity inpaint tool
however, Affinity photo’s inpainting tool has done a much better job in this case.

???
It doesn’t seem to have removed anything if it’s the guys on the forklift you are trying to remove!

it did remove them, look at the top image titled ‘after removal’ and the gen ai has created a black to grey gradient block, rather than generate some hedges like affinity photo did. This is the point i am trying to make. It is something that clearly needs some more training for the gen engine.

Your labelling was confusing. Now I see what you mean. Have you tried running Remove a second time?

I tried it myself on your JPG (presumably it is lower res here than your original.
This is what I got after two passes using quite a large brush.


And one pass, using a much smaller brush:

Note that I set the quality slider to maximum in both cases.

yes, i tried a larger brush area based on your suggestion, got a better result. this this the one issue with generative ai, its is like a box of chocolates, you never know what you are going to get.