Remove tool trial

I tried the remove tool Very disappointing. I remove a person from a photo of a field and sky. Instead of simply filling with grass it inserts random objects in the picture. Makes no sense. Simply must delete the person and fill with the same landscape, nut creating a new random subject. As it this tool is not usable in real life

Post a copy of the image and say what you want removed with the background infilled. I assume you have read the User Guide and know how to use it.

I want to delete the person. Here is a trial and the result.

This morning that is what I get, rather consistently. Yesterday for some reason that I don’t understand I was sometime getting similar results but sometimes an object was inserted to replace the person: once it was a Chinese person poorly rendered, another time it was what looked like a part of a tent. Today I tried half a dozen time and only got grass. The result is still not very good and a simple no AI repair tool in other apps does a better job, If I get the “dummy object insertion issue” again I will port the images.


All I can say is you are right that other apps, such as Affinity Photo Infill tool, would do a better job.

In this case I would select Padding none and Guidance Erase area.

b27b6c489d9d0859505ce7cc8f64be078f2eb08d_2_850x637-topaz-remove--sharpen-topaz-sharpen-sharpen-sharpen

I did another try at this and this time got one of those weird results I were talking about. See for yourself… The AI removed the real person and inserted another non-realistic one instead of deleting

In the help they mention an initial training process, as well and Padduing and Guidance settings. I do not have any of those offered to me. I wonder if something went wrong with the update …

Thanks for sending in those files and examples.

If you are still experiencing problems like these please reach out to us at the following link:

Topaz Labs | Support Page

I have made a note for our developers to look at these examples in this thread.