Recognizing my GPU

Updated Sharpen to 3.2 yesterday. In AI Processor field, in the Performance section of the Preferences menu I selected my GPU, a Radeon Pro WX 7100. The other choices were CPU and Auto, and I think the Auto choice was just recently added. As soon as I closed Sharpen and then re-opened it, the AI Processor field had “defaulted” to the Auto mode. Repeated this several times with same result. I would set the AI Processor to my Radeon GPU, and the software would default this choice back to Auto. Same field in Gigapixel shows my GPU without a problem. Anyone know why this is happening?

Experiencing the same situation here.

Application & Version: Topaz Sharpen AI Version 3.2.2
Operating System: Windows 10 Version 2009
Graphics Hardware: NVIDIA GeForce GTX 1660/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 471.11
CPU RAM: 32688 MB
Video RAM: 6144 MB
Preview Limit: 7817 Pixels

After installation of the update, found AI processor set to CPU, where it had previously been "NVIDIA GeForce GTX 1660’.

Changed the setting to "1:NVIDIA GeForce GTX 1660, ran a test image, then closed Sharpen AI. On re-opening found setting has now changed to “Auto”.

I see from the change log "Added auto detect option to processor preference ’
So the change gives settings options that are ignored, and an Auto mode with no indication as to what processor is actually being used.

Sorry, to me that is a backwards step.

Exactly. Like your situation, before the update this field showed my specific processor. As soon as I updated yesterday this same field showed “CPU”. When I manually selected my processor, it immediately defaulted to “Auto”. Of course if this auto setting looks for a compatible GPU and uses it, then all is good. But, not allowing us to manually select our GPUs sure makes me suspicious that it may not be using it. The software does not seem to be any slower, but I would like this corrected. I emailed Topaz yesterday afternoon, but of course this is a holiday weekend so I don’t expect to hear anything sooner than Tuesday.

I have dual GPUs on my system, a GTX1550 and Intel HD630, but I can select the NVIDIA and it stays selected. Do you both have dual GPUs that are supported as per the System requirements specs?

I only have one GPU, the Radeon. Running Windows 10, latest version, and accessing all of the Topaz software as plugins from Lightroom. Hopefully I’ll hear from Topaz on Tuesday.

Only one GPU, the GTX 1660 OC. Hasn’t been an issue previously, just with this update.

Raise a support request at the main website and say you would like to see the name of the GPU rather than “Auto” when there is only one GPU onboard.

I suspect that it switched to Auto when there is only one.

Received an email this afternoon from Topaz in response to the one I sent them describing the problem I was having. Here is the main point from their response:

The next update should fix this issue and the ‘‘AI Processor’’ will stick to whatever you chose before (like in Gigapixel AI). This shouldn’t affect the performance for you since Auto will use your GPU indeed, but you can rest assured I’ll keep you posted once this has been fixed.

Thanks for your help.