Recent Upgrade Constantly Needs to "Download Models"

Hardware: Apple Mac Studio M1 Max, OS Ventura 13.6.1
Software: Adobe CC Photoshop 2020

Everything was fine until the recent update

  1. Now, every time I use the filter menu: Filter > Topaz Labs > Topaz Photo AI it says it needs to “Download Models” (see attached screen grab)

  2. Previously, the filter took 10-20 seconds, now with the download it takes 2-3 minutes

Please advise, thank you.


Topaz Photo AI [v1.x.x] on [Windows/Mac]

1 Like

Make sure that Photo AI has full disk access through the Mac Settings to see if that makes a difference. Can be found in Security & Privacy Preferences > Privacy and click Full Disk Access from the left panel .

1 Like

AIDon,

First of all, wow for the quick response!

That Full Disk Access solution did not work. However, I discovered that if I use the Topaz Photo AI as a standalone drag-and-drop app rather than through Photoshop’s Filter menu, the issue is resolved.

Thank you for taking the time to respond.

-Ramsey

2 Likes

I wonder if PS needs full disk access as well because it is the host app and Photo AI is spawned from PS?

I don’t think so.

When your suggestion didn’t work inside Photoshop I turned the full disk access back off, and yet the standalone Topaz app worked fine with no full disk access set up for either.

Thanks.

1 Like

Have you tried disable “In-App Model Download” in Perference ?

2023-11-27_221502

1 Like

I am having this issue so constantly on my Mac Studio that I will be forced to give up Topaz tools. None of the above have worked. I don’t even HAVE an “In-App Model” option in Preferences. Very disappointed.

Not only, but AFTER I download (supposedly) a half-gig model file, I open a photo and preview won’t update and I get the “Downloading Model File” pop-up with 0% and nothing happens. Blood pressure meds time.

Let’s try updating you to the most recent version release to see if this resolves the issue.

Please make sure you’ve also turned off any firewall, VPN, or proxy that may be on your computer. These are known to block the installation. Also, make sure there are no settings or configurations in your OS system that could interfere.

Try using the appropriate OS system link to update:

Topaz Photo AI | Windows Installer

Topaz Photo AI | Mac Installer

If you are still experiencing problems, please reach out to us at the following link:

Topaz Labs | Support Page

@ramsey.said

if there are models missing on their computer (which you can check from the logs, it will show that a model is missing in the beginning of the log and try to redownload them)

  • run the installer again if the in-app model downloader is failing
  • troubleshoot security apps like antivirus, firewall, VPN
  • check if they have another internet connection they can use (hotspot usually works)
  • check if they have another computer they could try to see if it’s a computer issue or internet issue
1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.