Proteus is adding static noise to my output

I’m using Proteus to upscale some low-quality 3d animations and it sometimes likes to add a ton of “grain” (or whatever you call it) to the output.

See the difference in the zoomed up image below.

Why can’t it just do a nice blend of color like some other models do ? I’m quite frustated because I basically can’t do multiple runs in VAEI with the same video or it just becomes to grainy. My grain setting is also disabled so it can’t be that.

By chance does anyone know how to remove or tone it down ? Thanks.

I would try turning the denoise slider up by increments of 8 or 10 until you get the blending you want.