Program is not working at all

Hello, since yesterday the program stoped working completely.

Before that is was ok, even yesterday but I was encountering some problems (bugs, slower functioning). I am working on a MacBook pro 16, M1, 16GB 1TB (300GB free) so it shouldn’t be an issue. For the first week that I had it worked seamlessly. Now, I am placing in any photo, even super small and it’s stuck. Zero results.

Buttons are not responding, and it’s taking 99.9 % CPU. This has not been an issue before and I worked on much larger photos, while now I try to upscale an 1500px and 750KB picture.

Sounds like something has changed on your PC… recent update? new OS? beta OS?

My system is similar and I am experiencing no issues of that kind. I am running a Ventura beta so it’s not that, although I have no idea how TPAI is running with the Sonoma beta.
I suppose the best plan is to use AppCleaner to clear TPAI out of your system and then reinstall it.

You did already try a simple reboot of the Mac?

Hello, I have the same problem, it’s as if the software doesn’t take into account any image at all. I saw that I had an update available, so I did it thinking that the problem came from there, but once done, I remain in the same situation. I then deleted the application from imac24 m1 16go, and downloaded it again from your website. And I still have the same problem. The application does not respond, sometimes the image appears, but appears as always in processing and nothing changes on the screen. I’ve even checked to see if my hard disk was full and preventing the application from working properly, but it’s not. Now I don’t know what to do… If anyone has a solution to report, I’m interested. Thanks

yes, i tried, and reinstall every thing…

Make sure that Photo AI has full access to write to your disk … check in settings.

Thanks for the answer, but could you please be more specific? I’ve searched and searched and I can’t see where to grant this access. Thank you

Screenshot 2023-08-07 at 8.10.48

Also, did you use AppCleaner or similar to remove TPAI. Just trashing the app won’t clear out all the folders in you Library.

I’ve just authorized it, but I can’t see any change. I’m going to try cleaning with AppCleaner, as you suggest.

Let’s hope it works.

All right, it works! Thank you very much for your help.

No recent updates or changes, I rebooted the Mac and reinstalled the program, no change

How did it work for you? I unistalled with the AppCleaner and I have this same problem. App is stuck, takes 99% of CPU and can’t even process the smallest image. I have an older version on my other computer and somehow it works :smiley: I have no idea what happened.

Maybe you need to check your settings and switch from CPU to Auto or whatever your built-in GPU is. With me, Auto works fine.

It only worked once, and didn’t work again after I tried it yesterday. I’ve just tried again, and no, the software doesn’t work at all, it’s stuck on “loading image” and doesn’t display an image. I don’t know what’s causing the problem, but it’s getting really annoying, as I use it for work… I don’t know what to do, especially as my subscription runs until January 2024…

1 Like

Hi, I’ve just tried it, but the “settings” button doesn’t respond, so I can’t even try your solution…

& @paulina.nowak

Please follow the instructions below to fix this issue.
Topaz Photo AI Freezes on Importing Image (Mac)

Let me know if it’s working after doing this.

Hello, thank you for the answer :slight_smile: I deleted the files, and restarted and this same problem occurs. It’s frozen on the importing image, I use the app for work and it has been already a week like that… I tried on a second computer where I’ve had installed an older update (like 1.1) and it works, even tho it’s 13in Mac 500gB.

It really seems like it’s this new update that has been causing trouble but I might be wrong. Also, before it ‘broke’ I was working on TIFFs and CR2 raws that were output to quite large sizes. Did it just ‘overheat’ ? :smiley:

Please reach out to I can take a look at the issue and see if there is something else happening.

Deleting the 2 plist files and rebooting should fix this entirely.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.