Problems with processing Sony AWR raw files

I have not been able to successfully edit Sony ARW files with Topaz Photo AI or Sharpen AI (have not tried others). The image editing process proceeds normally. But saving the result as a DNG file ends with only the small 256x172 replica saved. However, the file size is 142 MB. Converting the files to DNG first permits a normal outcome. If I save the file in a TIFF format, the process is completed successfully

I also tried processing different ARW file with the latest version of Topaz Denoise, with the same outcome. I ran two edits, one running a “Standard” setting and a second using a “Raw” setting. the output DNG files are both 141 MB and 256 X 171 dimensions.

Note the previous generated TIFF file, with the somewhat weird 5975x4024 dimension
This outcome is not consistent with my expectations and I am disappointed with the result. If I am expected to be satisfied with the TIFF output I want a confirmation and explanation.

I have a similar issue with Gigapixel AI. If I try to crop a Sony raw file it just stays in not updated status. If I convert the image to jpg. then it resizes as it should.

It s that the problem lies entirely with Microsoft file explorer, The listed dimensions are wrong