Problems with Jpeg to Raw and Gigapixel AI

The problem I am experiencing is weird Distorted Images when using Jpeg to Raw and Gigapixel AI and Lightroom. This problem only occurs when I am working with iPhone images. I normally don’t do much with my iPhone except for taking family snapshots and I felt Jpeg to Raw and Gigapixel would be a good combination for editing iPhone Jpeg images and upsizing them for larger prints. As I mentioned already, my normal raw files and Jpegs are fine. Also, I want to note the problem doesn’t occur when using ACR and Photoshop but only when bringing Lightroom into the mix which is what I use for my normal workflow. I tried ACR just to see if I could pin point the problem. So I narrowed it down to Jpeg to Raw, Gigapixel and Lightroom.
Here is my Graphic Card Info: Application & Version: Topaz JPEG to RAW AI Version 2.0.1

Operating System: macOS 10.14

Graphics Hardware: AMD Radeon RX 580 OpenGL Engine

OpenGL Driver: 4.1 ATI-2.8.38

CPU RAM: 65536 MB

Video RAM: 2047 MB Total, 2047 MB In Use

Preview Limit: 4492 Pixels

I am using a Mac Pro and the latest version of Mohave.
By the way when I use ACR and Photoshop the results are fine but as soon as I import the image into Lightroom the distortion occurs. This is really a strange issue.

Another side note is that when I export the iPhone image as a Tiff and upsize it in Gigapixel AI the distortion will not show up in Mac Previews and if I opened it up in Photoshop it would be fine and I could print the image from Photoshop. But as soon as I import into Lightroom the distortion appears. Another interesting scenario is that if I export the image as a Jpeg and upsize it in Gigapixel AI and then import it into Lightroom it will be fine. This is quite baffling. I hate to be long winded but I wanted to fully describe this condition.

When I export an iPhone Jpeg to Jpeg to Raw the image will be fine in the Mac Preview and also in Photoshop but the minute I import it into Lightroom it is distorted. So basically Jpeg to Raw and Gigapixel AI are doing pretty much the same thing. Here are the results:

I am submitting a ticket on this issue in customer support. I lost many hours trying to figure out a work around.

Hi David,

It does seem strange that only Lightroom exhibits this problem as Lightroom will be using the same version of ACR as PS. (Help About will give you the Camera RAW version in LR and Help-> About Plugin - Camera RAW in PS).

Have you tried regenerating the preview in Lightroom to see if that makes a difference?


I know it seems strange Don but it is not effected using ACR and then editing in Photoshop. The minute I take the final edit and save it and import it into Lightroom the distortion occurs. For the life of me I can’t figure this out. I also have regenerated the previews but to no avail, the distortion remains. Like I said this condition only happens with iPhone images. This problem occurs whether I use a jpeg iPhone file, DNG or HEIC file. Pretty strange.

One other note of interest. I had a couple of times when I imported the iPhone images to not show the distortion upon import but as soon as I adjusted any develop slider the distortion immediately popped on. Really strange.

Yes your right as it is strange.

I noticed there are threads on the Adobe Forum about distorted previews but only in the Library Module, if it is being Developed they seem to be OK. But I don’t have the latest versions only LR/CS-6 and there are no issues on Win.

Hopefully the devs will be able to isolate it.

The odd thing is it is only iPhone images which are causing this. All of my Raw files and Jpegs are just fine. I purchased Jpeg to Raw so I would be able to get better edits with my family images and Gigapixel to make larger prints. I basically use the iPhone for family snap shots.

1 Like

Problem is solved. By the way the new updates to Gigapixel AI and Jpeg to Raw seem to have corrected the problem. Prior to installing the new updates I found that Gigapixel AI and Jpeg to Raw were adding a wrong Lens Profile to my iPhone images. I will include a screenshot so you can see what profile was being assigned. The fix was to either choose None for the Lens Profile or Apple. As you can see it was applying a Moment Superfish Lens Profile to my iPhone File. Pretty weird but the problem is solved. Like I said the new update seemed to fix the issue.10%20PM