Problem with plugin Lightroom Classic en DNG Raw file

I have a problem with Plugin L.R. Classic (16.2) with DNG Raw file and get error message.
I bring my DNG RAW file (from a Pentax camera K3 III) into Photo AI from Lightroom “process with Topaz Photo A.I.” and can edit it as usual but when i try to safe it as a Raw file back into Lightroom it gives me an error message saying: “Failed to import processed photo. Processed photo may be from an unsupported camera or malformatted file":
E:\Mijn LightroombestandenvanLR\2023\2023-01-11 Strabr.Heide\20230111-_IMG7507dng.
AgImportSession.addOnePhotToLibrary:failedtoimportphoto and doesn’t save it into Lightroom.``

Schermafbeelding 2024-05-12 143153

Topz Photo Ai 3.02 on Windows 11

2024-05-13-18-19-19.tzlog (136.0 KB)

Unfortunately, we have identified this as an issue while working with DNG files using the Lightroom plugin for Topaz Photo AI. Our developers are investigating why this is occurring, and I have added your service ticket for their review.

We will be sure to reach out to you once we have a solution for this and have released a fix.

Currently, I would recommend choosing one of the following workarounds:

I can assure you that our developers are working hard to resolve this problem.

1 Like

New version worked only 1 time,
there is no return as dng file anymore
I have to go again to > show in finder>open with Topaz Photo AI etc…for getting back a DNG

Lightroom plugin does not download processed Leica raw DNG files.

Steps to reproduce issue:

  1. Select a Leica DNG file in Lightroom Classic
  2. From File Menu, process in Topaz Photo AI
  3. When process complete, download to Lightroom
  4. Error message appears.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Exactly the same problem with Pentax raw DNG file with at the end the error message.

@chetbuddphotography @CvdC

Would you mind telling me which Lightroom Classic plugin you are using from the list below:

  • The RAW plugin, accessed through File > Plug-in Extras > Process with Topaz Photo
  • The External Editor plugin, accessed through Photo > Edit in > Topaz Photo AI

Also, if you can, please try to recreate this error message in Topaz Photo AI, then go to Help > Open Log Folder; please send me all of the files within that folder. You should be able to attach them directly as a response to this thread.

If you are receiving any error messages while trying to use the Lightroom Classic plugin please take a screenshot and send that in to us so we can get a better understanding to help troubleshoot.

You can securely submit your files(s) to my Dropbox using the link below. Make sure to send me a note to let me know you sent something. :slight_smile:

Dropbox File Request

I use Fileprocess with Topaz photo AI.
Then Topaz tries te send back the DNG file to Lightroom and inLightroom there is this message:

Schermafbeelding 2024-05-14 110216

I sended the log file with Dropbox

`

I have the EXACT same issue. Pentax K1-M2. New issue. I’ve not had this trouble before.

Well, for that main issue, I’ve outlined above the steps to reproduce:

  1. Take image in Lightroom (Classic) and go to File → Plugin-Extras → Process With Topaz Photo AI
  2. Sharpen image in Photo AI
  3. Export photo back into lightroom
  4. In Lightroom, the original DNG got overwritten with the new processed image instead of creating a separate copy and stacking them.
1 Like

I just started using LrC File → Plug-in Extras → Process in Topaz Photo AI instead of edit in external editor to preserve DNG format and metadata. My Pentax cameras create DNG files by default so that’s what I’m editing in Lightroom Classic.

But when I edit one of these DNG files in Photo AI 3 then export the edits back to Lightroom, the result is my original DNG is deleted and replaced with the Photo AI updated one. That means I lose the original and along with it any Lightroom metadata like exposure, etc., that has been changed on it.

Photo AI should not overwrite the original DNG. It should give the exported one a new name like IMGP3167-photoai.dng to helpfully indicate it’s a new version of the OG. Ideally I should be able to set what that new name suffix will be.

I launch Photo AI from LrC as a plug-in. I do my normal editing in Topaz and have an acceptable photo. When I export it back to Lightroom Classic it doesn’t show up in the photos next to the RAW file I started with. I can’t find it anywhere in LrC but it is on the hard drive. It appears I have to import the edited file from the hard drive location back into Lightroom. In the past the new file (DNG or TIFF) would just appear next to the RAW file in LrC when I finished with it in Topaz. Please let me know if I’m not doing something correctly.

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

I have similar issue. My fails to import completely. However, I can open outside of LRC, process image and save with issue and then open in LRC. This is a new problem for me after the latest 3.0.2 update.

Which Lightroom plugin are you using where you are having this problem:

  • The RAW plugin, accessed through File > Plug-in Extras > Process with Topaz Photo
  • The External Editor plugin, accessed through Photo > Edit in > Topaz Photo AI

You can also want to go to your Preferences > General > External Editors and make sure that you have the option to Place processed images in the original image’s collections is enabled.

File to plug in extras

This worked fine until 3.0.2

1 Like

I am having this same issue. Was fine until the last update. Now I have to find the edited file in my hard drive and import back into LR but then I end up with 2 copies of the file in the folder for that catalog. Hope you can fix it. Thanks.

Same issue - if I process from within LRC then save in TAI, it saves by OVERWRITING the original photo. As jack.cooksey said, if I open outside of LRC, process then import to LRC it works.

John.topazlabs : my Preferences > General > External Editors > Place processed images in the original image’s collections is enabled. It makes no difference.

So now TWO issues : this and the fact that the brush tool in selection is still jerky and lagging - this has been for several months.

Would be nice to know time from for both these problems to be resolved. Right now have paid for another year and am wondering now why!

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]
Images sent into Topaz AI from Lightroom Classic (File-Plug-in extras- Process via Topaz photo AI) image de-noised & returned to Lightroom Classic, Topaz shuts down, Lightroom generates error message, screen shot added.
Screenshot 2024-05-15 at 15.57.37

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v3.0.2] on [Mac]

Verified this, yes. This option in Lightroom was always enabled on my end to stack the edited photo along with the original, NOT overwrite it. This was working fine until the 3.0.2 broke it. Have you been able to reproduce the problem? Seems a bunch of people are running into problem.