Preserve Text refusing to be selected

I keep on trying to select text to be preserved in aircraft photos but it is not being selected, so I try again and again and sometimes it does select it but the process is so painfully slow.
The last time it finally worked was when I clicked on “select all” then “select none” and finally select the area on screen.
I can send photos if necessary.
Having tried it some more, it seems that it is forcing me to wait until it has previewed the Sharpen process before allowing me to select the text, which can take a couple of minutes each time.

Steps to reproduce issue:

  1. Step 1 - select Preserving Text
  2. Step 2 - select the area on the photo with text
  3. Step 3 - select Apply

Topaz Photo AI v2.3.1 on Windows

Would you mind sending in some more information to get a better understanding of the problem you are having with this particular type of image? Please send the following information:

  1. The original image file.
  2. The processed image.
  3. A screenshot or description of the settings panel so I can see what adjustments were turned on.

You can securely submit your image(s) to my Dropbox using the link below.

Dropbox File Request

Please be sure to send me a note to let me know you sent something.

John
Thanks but the photo is not the issue, it is the process of selecting Preserve Text that is the issue.
I have come to realise that it just takes an eternity for it to allow me to select the text.
I presume it has to go through the process of loading the image, previewing it with De-noise, sharpen etc before allowing me to select the text.
I know this because I click on “Select all” from the Preserve text menu and then sit back and wait for ages before the image finally goes red, meaning that I can now click on “Select none” and then select the actual text I want.

Kind regards
Rob