Photo AI wouldn't update, then tried to update & deleted old copy then crashed and I now have nothing

I tried to update Photo AI. The first time I got an error message saying it wasn’t compatible. The second time I downloaded it, the installation started, then while it was downloading the 4 modules or whatever, the internet connection timed out. Then the dialog said that since an error accrued that my system wasn’t changed and to run the installer again. I can’t do that because I have no idea WHERE it downloaded the installer to. What it did do was remove the copy of Photo AI that I had and now I have nothing, no program at all.

What can I do to get it back? Please make these updates so that it downloads to a folder that the user knows how to find it, give the path to the folder so in case something like this happens, the user can find the installer and run it again. And stop making so that first a 674 megabyte file is downloaded, and then during the install it has to download more stuff. Put it all in ONE DOWNLOAD so this stuff doesn’t happen to people.