Photo AI v1.5.4 Crashes Win11

Photo AI v1.5.4 (and previous 1.5.3) crashes during save to .jpg or during autopilot.

Have single raw image open in Photo AI. Randomly crashes when saving to Best quality/100% jpg
Have single image open, system error message and Photo AI stops working.
It is random and do not know how to replicate.

Same issue occurred in 1.5.3 and following update to 1.5.4

Steps to reproduce issue:

  1. Step 1

  2. Step 2
    DxDiag.txt (92.9 KB) (1.5 MB)

  3. Step 3

Topaz Photo AI [v1.5.4] and previous ver [1.5.3] on Windows 11

1 Like

Also happens when saving to DNG

I have the same issue!!!

Thanks for sending the logs. The errors show that there was insufficient memory when processing the file.

I shared the log with my team so we can look into this.

As far as i can see, my pc meets or exceeds the minimum system requirements on your webpage, I have 16Gb of ram and 4Gb DDR5 vram attached to the GPU which is also above your min. requirements.

Look forward to the response

Running other programs at the same time could be using your system memory and causing this error.

This is especially the case with large files such as Raw or DNG.

Please try processing again with other programs closed and let me know if you run into the same error.

There are no other applications running. I have turned off background services.
I checked this as a solution before lodging the bug report.

I have doubled the ram, i have altered processing from cpu to gpu and back again. It still crashes. Perhaps it is the software and use of resources? If it is still crashing with 32Gb of RAM, something seems out of whack.

With those specs, if the error is still happening then this is absolutely an application error.

I am bringing it up in the weekly meeting so we can have someone work on it.

Does it happen with non-Raw files?

I have only tried a couple of different jpg’s and it hasn’t crashed yet. Still crashing with raw files generated from camera (D750, D7000 and tiff from scanner).
When used as a plugin from Affinity Photo 2.1, it also randomly crashes.

Does Affinity Photo have memory usage controls? Photoshop has a Preferences > Performance tab where you can decrease the memory usage, which may help prevent this behavior.

I asked my team about this error and it’s coming from the operating system telling Topaz Photo AI that there is not enough memory. That wasn’t a useful answer for finding a fix unfortunately.

Could you try changing the Preferences > General > AI Processor to CPU and let me know if you see the same error?

Affinity is set at about16Gb of RAM. This is double the recommended system requirements.

I am speaking to a user about this issue tomorrow to check what is happening.

I can check in once I have an idea of a fix.

I have updated to version 2.
It is stable and not crashing like it was. No system changes on my part.

From this it appears to me to have been a problem with Topaz Photo AI causing the excessive memory usage and subsequent system crashes and not my pc having insufficient resources.

However as the actual cause of the excessive memory usage has not been identified it hasn’t necessarily been fixed by the release of V2.

Thanks for letting me know. I’ll look out for other users with similar issues to identify the cause. Please let me know if it happens again.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.