Photo AI Not Using GPU on NEF Files

When using autopilot on NEF files that are set to use “Strong” noise reduction, it does not use the GPU and takes a long time, if you override and use the “Normal” setting it uses the GPU and is much faster. Working on jpeg files for noise always uses the GPU.
The sharpening stage uses the GPU fine on all file types.

Steps to reproduce issue:

  1. Choose noisy NEF file
  2. Allow Autopilot to initiate sequence
  3. Use MSI Afterburner to watch GPU usage

Any ideas

Topaz Photo AI v1.3.6 on Windows using NVIDIA GEForce GTX 1660 Ti
2023-05-30-09-42-5.tzlog (547.9 KB)

I can confirm the same issue with the “Strong” denoise setting not using the GPU (RTX2060) with .NEF files.

“We have temporarily pulled back the GPU models for denoise in particular because they were causing stability issues. So at the moment denoise will be slower than it was previously on Windows machines. We are working on adding them back as well as updating the denoise models in general, but those models are still in beta.” - it has been fixed in the BETA denoise model for non-RAW, but not in the RAW versions yet.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.