Photo AI "internet connectivity error" prevents installing *and* updating

I’ve been trying to update Photo AI for weeks now but always get an error that reads, “Internet connectivity error. Verify connectivity before retrying installation.” To try to eliminate potential problems I have done the following:

  • I quit out of Photoshop.
  • Disabled Windows Personal Firewall.
  • Disabled Windows Defender virus protection.
  • Restarted the computer.
  • I downloaded the full installer and tried to install over the existing version.
  • Confirmed that my Starlink connection was not experiencing any interruptions during the times I was attempting to run the updater. My connection usually has between 20mbs and 200mbs.

The problem still occurred. In desperation, I did a complete uninstall of the program, restarted, and ran the installer, but it also failed. Now I no longer have Photo AI on my computer, nor any way to install it. This is a product I regularly use for work, so I need to get it reinstalled ASAP.

Video AI installs/updates with no problem.


Topaz Photo AI 2.0.3 installer on Windows 10.

Thanks for reaching out. Are any of the model files downloading? The download may be stopped partway, but if there are model files downloading then running the installer again should continue downloading more files.

We are working on an in-app model downloader in case the installer is not downloading the models properly.

I can’t tell exactly what is successfully downloading – it looks like quite a bit is coming down before the installer errors out a minute or two into the lengthy install process. The progress thermometer goes across the installer windows a bunch of times.

I have tried running the installer at least 6 or 7 times in a row without success.

Please follow the below instructions to get the installer log for Topaz Photo AI.

  1. Delete all Photo AI installers from your Downloads folder.
  2. Download the latest Topaz Photo AI installer from the downloads page: Download
  3. Make sure the installer is in your Downloads folder and has the filename: TopazPhotoAI.msi
  4. Open Command Prompt from your Start menu. You can type in Command Prompt in Search and open it.
  5. Copy and paste “cd downloads” (without the quotes) into the Command Prompt and hit Enter.
  6. Copy and paste “msiexec /i TopazPhotoAI.msi /l*v logfile.txt” (without the quotes) into the Command Prompt and hit Enter.
  7. The installer should open up. Run it as usual.
  8. After the installation finishes, please send me “logfile” created in your Downloads folder.

This should show me exactly what is happening in the installer that is blocking the internet connection if the issue isn’t any of the above security applications.

Here you go - thanks for the help.

logfile.txt (3.6 MB)

It looks like one of the models downloaded but the larger model failed.

The in-app model downloader will be released next week which should allow you to download the rest of the models.

For now, do you have a hotspot you could use to try and download the models? It seems like the Starlink connection is not suitable for the installer model download.

Unfortunately, I do not have any other Internet connection.

Does the in-app model downloader require the app to be installed? Because the error I’m running into is not with updating the installed app, I’m trying to install the app itself. Unless the new version allows me to specify that I want to install the app without the models, then I won’t be able to install at all.

Also, I just want to point out that I was previously able to install both Photo AI and Video AI a few weeks back, but something changed and I cannot install Photo AI at all now. Video AI is installed and updates just fine.

Topaz Video AI uses an in-app model downloader.

The next version of Topaz Photo AI with the in-app model downloader will continue the installation even if the model download fails and finish the application installation. It will then download the models when you run the application.

Cool, sounds perfect - thanks!

It should be releasing this Thursday! Please update to v2.0.6 after we release it and let me know if it’s working for you.

Hello,

​We just released v2.1.1 which has a fix for the installer not downloading model files. The model files will be downloaded in the application instead.

​Please update and let me know if the installer is working now and if the models are downloading in the application. You can update in-app more get an installer here:
Download

1 Like

Thanks for the excellent support. The last installer actually fixed it. I’m good to go - thank you!

I’m having the same issue. Using starlink firewall and vpn disabled and fialt to download a 1.6GB model. It does not carry on with the instaltion. So I’m still stuck. I’ll try delating the software and see whats happens

Unstialling the old version did not make any difference. Just stuck in an endless cycle of hoping to get through the download before it stops. I’ve got as close as 1.4GB of the 1.6GB file. I’ve also dissabled the content filter on the starlink router and added an exlusion on widows defender for the photo ai directory. Any other ideas?

If it’s helpful to know, I’m using the original Starlink dish & router which is working for me now.

Sorry for your frustrations, sir - I feel your pain.

Thanks, I have the original Starlink as well. So it must be something other I guess. Though why the install is not skipping past the download issue liked is reported us supposed to do with the latest version is very odd

Stupidly never tired opening the application after the installation failed. Now I have it works. I’m assuming it will download the missing files as when they are required

If you are using NordVPN, don’t just disable but try fully quitting NordVPN.

Same issue here, sometimes it downloads enough files to launch but it’s missing models, none of the features work.

Starlink as well, i can download the installer at 25MB/s but as soon as the installers running it goes from 10MB/s to 2MB/s then freezes and says internet connection issue.

Seems like an issue on their server end.