Photo ai disappeared from PSE 2023

Photo ai always showed up under “filters” in my Photoshop elements 2023. After the last update it disappeared. What happened and how do I get it back?

Photo AI won’t show under filters as from there you cannot enlarge or reduce the size of the canvas in a filter when you resize the image.

The issue is not noise reduction, sharpening or enhancement but all 4 actions including the resize option are there.

If you have DeNoise AI and Sharpen AI they will show up under the filters.

1 Like

Actually, I had Denoise, sharpen and photo ai all under my filters, until I did the last update for photo ai. Now they are all gone, how can I get any or all back?

Just search for it and Google will direct you to this …


The same happened to me, but i have PSE 22. First I was unable to save a photo in PSE, later the plug-in vanished from PSE. I’m not sure if it happened just after updating to 1.2.8.
I updated to Photo ai 1.2.9 today, followed the above instructions, but that did not work.
Windows 10 home, 64
What have I done wrong? Thanks for your suggestions.
John G.

The answer to your question is 3 posts above.

1 Like

Hi Don
I followed the above instructions, got the picture at point 4, preesed ok.
But the plug-in is not in the "filter2 of PSE 22, but in the “filter” of PSE 14, which is still on my PC.
I should find a way to change this, as it was before. This happened on its own. i wonder why.
John G.

Hi all, I too found that Photo AI had disappeared from the filter list after updating. Denoise AI and Sharpen AI were still there, but Photo AI was not. I followed the Topaz guidelines for plug-ins exactly a number of times; however, they did not work. No matter how many times I tried it, they did not work.
I have the latest Topaz Photo AI version (1.3.0) installed, and Photoshop Elements 2023.
I found a possible solution on the Adobe Community site. See below:

Solved: Trouble Attaching Topaz to Photoshop Elements 2023 - Adobe Support Community - 13424450.

Essentially, in addition to the Topaz instructions, I drilled down to C:\Program Files\Adobe\Photoshop Elements 2023\Required\Plug-Ins, then created a directory ‘Topaz’, and copied the file ’ TopazPhotoAI.8bf’ from the Topaz Labs LLC directory, into the Topaz directory I just created. Upon restarting Photoshop Elements 2023, Photo AI was back in the list… and opens.
I hope this makes sense, and helps others.

1 Like

It worked for me too.
i hope it persists after updating to TAI 1.3.2
John G.

1 Like

This is much too complicated. Topaz needs to work on a fix.

1 Like

Working on it!

Hi admins
Here I am again: After the update 2.0.1 the plugin did not work in PSE 22 nor in PSE 14, even if it shows in the filters. The same after updating to 2.0.4.
I got this error message:
Topaz Fehler
I had to close PSE 22 with the task manager.
I copied the AI8bf file as instructed, but to no avail.
It works with PSE 14, but first showing the error message, 10 sec later it opens TPhoto AI.
Is there an easy solution for this issue?
Thank you
John G.

When you see that message, you’ll have to navigate to Photo AI and finish processing and export the image back into Photoshop.

Hi Tim
This does not work. I have to close PSE22 with the task manager, as nothing other works.
The photo is not found in P AI to be processed.
John G.

After updating to 2.0.5 I found the new folder where I had inserted the …8bf-file in april, as mentioned above.
I now inserted the new file from oct 12th, and it works now again, with a wait of 7 secs.

John G.

1 Like