Photo AI and Denoise output images too small (256x171)

I have searched through the forums, but have not found an answer. I’m hoping someone has found an answer. In both Topaz Photo AI and Denoise AI, I have the same results and it is getting old. I know what I am doing. I shoot a lot of higher ISO, low light photos and I like the end results of the denoise process. The program works relatively fast and smooth, but the issue is the output size of the image from the Denoise process. Both apps output the file size correctly, but the image size for processing is always wrong. Just for numbers sake, the image goes in as 25Mb (does not matter if DNG, CR3, CR2, TIFF, etc.), 6960 x 4640. The embedded output file size will be from 25Mb - 190Mb with an image size of 256 x 171. This image size of 256 x 171 is the image to be processed in PS, ACDsee, Luminar AI, Luminar Neo, Topaz Studio, Topaz Adjust amongst others. The image is worthless. The ONLY way I can use the image is to import it into Lightroom and immediately export it to DNG. The file then has the correct file dimensions of 6960 x 4640 or what ever the original dimensions were. Again, it does not matter what the input file type is or the output type. I have tried completely removing the software and reinstalling (suggested by Topaz) with the same end results. I have been using this software (yes, the oldest to the newest version), for several years now, but am tired of every time, running Denoise/Photo AI and then import/export through LR, to get an image that can be processed. Has anyone found an answer?

All the time I’ve been on this forum, I don’t recall hearing of a problem like this before. The tiny 256x171 image sounds like an embedded thumbnail in the file, but I’ve no idea why other applications would have a problem recognizing that and not be able to open the file properly at full size.

It sounds like you’ll have to provide an example of one of these input and output images, if anyone has any hope of working out what is going on.

EDIT: Hold on. This sounds like a problem related to this:

But for you it’s happening with all output file types?

So it is happening with JPEG, TIFF, PNG as well as DNG?

What versions of Photo AI, Sharpen and DeNoise are you using?

What version of Lightroom are you using?

What applications have you tried opening them in that don’t open them correctly?

I went back and read what I posted. Perhaps I didn’t quite make clear on the file types. It doesn’t matter what file type for the input. The processing of the input file works well. The output I use is always DNG. I don’t have the versions of the software from the PC I am typing this from, but they are all the latest. They are all updated continuously. Lightroom, I can tell you, is LR6. I have it on the system, but don’t use it, except for this. All apps that I use, do not open the output DNG correctly from Denoise or Photo AI. TIFF’s, PNG’s open correctly from Denoise and Photo AI. DNG outputs from all other software, open correctly, PixInsight, Star Tools, Gigapixel, Sharpen, DxO PureRaw.
Microsoft Photos and One Photo Viewer open the output files the same way. It appears when Denoise and Photo AI are outputting the DNG, they are put the thumbnail as the main image, but storing the main image still with in the file. Lightroom for some reason, is able to see the main image and when resaving it to DNG, stores it correctly. This started about a year ago with one of the updates for Denoise and continued with the introduction of Photo AI. Again, the other Topaz apps are working correctly.

Here is an example. It is 185mb. Don’t go by the image in Box. Download the image and open it.

Hi, this is the default behavior right now for our apps – our apps save DNG files with a thumbnail-sized preview. Since the default Photos app on Windows can’t read DNG files, it reverts to reading the JPG preview’s dimensions.

We’re working on implementing full-sized JPG previews for DNG images in Photo AI, so keep a lookout for this update.

1 Like

Right now, I am completely frustrated. For over a year, I have been having to import the images into LR and then export them to be able to edit after Denoise. Just to re-state, the image that I had to work with after the Denoise, WAS the thumbnail, not the image. Between yesterday, when I uploaded the example image to “” to show what was going on, and today, after a year of doing this and threatening to go to your competition, all of a sudden the full image is coming up for edit without the import and export to LR. When I uploaded to the “”, I redownloaded the image to make sure it was going to show what was happening. Today, everything is working as normal. Will update if the issue returns. The only thing that I did different, was I updated the Topaz Photo AI. If this happens again for you, please reach to our support team directly at so we can dig into this a bit further, this sounds like it may be a little different than the behavior I had described above – the thumbnail image should only have affected apps that cannot read RAW files fully, so if you were getting only the thumbnails visible in Lightroom, then this is not expected behavior for our apps.

There are DAM applications and other viewers which use only the embedded JPEG for previews and culling and fast image browsing, Photomechanic for example. Topaz Photo AI images cannot be handled in the same way as Sharpen. Denoise or Gigapixel AI processed images

I recently just bought the Bundle and Photo AI. I’m on a Mac. Denoise without fail will turn any DNG into an extremely tiny dimension. I can’t even see what I’m supposed to be doing. It then outputs the same extremely tiny file. I do not understand this. Searching all over, no idea what to do. I uninstalled and reinstalled, nothing.

Hi @AdemVessell, please reach out to our support team at for DeNoise AI, we can help you with that app there.