Photo AI 1.3.11 Constant Crashes

Steps to reproduce issue:

  1. Open Photo AI 1.3.11
  2. Drag n Drop a photo to work on
  3. Adjust settings to “high fidelity” and enter in custom values
  4. Crashes something like 70% of the time…

Topaz Photo AI v1.3.11 on Windows - AMD Ryzen7 5800X3D, NVIDIA RTX A4000 16GB.

I have tried uninstalling, re-installing, using different versions (1.3.8, 1.3.9, 1.3.10, 1.3.11) and updating GPU drivers (currently NVIDIA RTX/Quadro 536.25).

Logs attached
Logs.zip (27.8 KB)

1 Like

Photo Ai plug in on Photoshop crashes all the time…

Following the release of 1.3.11 I have also experieced similar issues after updating the Nvidia Driver to 536.25, I believe the problems maybe caused by a recent update Nvidia applied to the drivers version. The workaround I found was to render the images using my CPU for the interim.

@menthurae @matthew.woodford I’ve seen a few reports of these newer Nvidia drivers affecting Topaz Photo AI – are you both able to downgrade to a previous Nvidia driver? This should let you use your GPU once more while we wait on another update from Nvidia.

Hi as suggested I have rolled back the Nvidia drivers to an earlier build which now seems to have resolved the crashing issues, based on this I believe it is the Nvidia drivers realised last week causing Photo AI to randomly crash when loading any image.

536.23 is a game ready driver. For photo processing your better off using only studio drivers. They are better tested than game ready ones and focused on photo/video/… processing

Actually Game ready drivers are tuned for higher frame rates over accuracy. That’s what’s important to gamers. Studio drivers are better tuned for graphics studio work. They are not exactly the same code. Same base code, yes. It’s the tuned up part that makes the difference.

If you look on the NVIDIA forum there are issues with the latest Studio driver v535.98 and they have recommended using the Game Ready driver v536,23 until the new Studio driver is released. Other Image Processing products are seriously affected by this studio driver.

For me - the crashes have been happening for quite a while and even with the previous version(s) of the NVIDIA drivers. To quote the 536.25 page:

Release 535 is a Production Branch release of the NVIDIA RTX Enterprise Driver. Production Branch drivers are designed and tested to provide long-term stability and availability. These drivers are ideal for enterprise customers and professional users who require application and hardware certification and regular driver updates for the latest in driver enhancements and security improvements.

I will try changing the drivers when I get a chance - though as I mentioned above, this has been happening for quite some time now.

Keeping the drivers on a certain version ideally should not be a “solution” - how long do I need to run out of date drivers for? Hopefully the issues are identified and the software catches up…

You will notice the game ready drivers are generally released more often than studio version. Why? From what I read they have the latest updates that are focused on games. They tend “push” the GPU more and thus are less stable. Is it the same code? I’ve had many discussions online about that. I never compared the size of the different files that are installed. But I can say when the game ready and studio that have the same version number the installer are different sizes. Why? Bottom line for photo editing studio drives are the best way to go. The issue that you read on the Nvidia forum indicates that there is obviously some bugs in the latest studio driver for some apps. My recommendation in that case would be to go back to a previous studio driver version not to a newer game ready one.

Game ready 536.23 is stable and works for a couple of imaging apps I use as well as DeNoise and Sharpen which 535.xx for Studio is making issues.

BTW I wasn’t asking for a recommendation I was just starting facts :grin:

So I changed to the NVIDIA 531.41 drivers and still it’s crashing quite a bit. For the meantime I have reverted to CPU processing and that is much, much more stable (have processed over 100 images and no crashing).

With the GPU it would crash every 2-3 images or even every image if I apply certain settings).

I can provide logs again if need be…

You should upload the logs to this thread as the devs would want to have a look.

Here we go - new logs… generated by loading in a bunch of images, going through as per my initial post and right on cue after a few images, crashy crash crash…

2023-06-27-20-31-5.zip (53.4 KB)

Following the isses with the latest drivers I rolled my drivers back via a Fresh install to the below driver version, Photo AI has remained stable since reverting to this driver version.

image

Thanks for sending the logs. I documented this for my team and we are building a new version of AI Engine soon which should address this.

Please continue updating Topaz Photo AI and you will get the AI Engine update when we release it.

Ever since I downloaded v. 1.3.12 update it crashes when saving and going back into my Photoshop Elements…that hasn’t been a problem before this latest update!! Needs to be a fix on these “new & improved” software updates!!!

Please send me the logs. Open Topaz Photo AI, go to the menu bar on the top and click the Help > Open Log Folder menu option. Attach the logs files you see.

I should be able to determine what is happening and send next steps with this information.

Thank you for replying! I downloaded 1.3.11 (after deleting 1.3.12) and it worked fine as always…I hesitated to download v 1.4 but I did this morning…and so far it works flawlessly! I have saved the 1.3.11 download in case 1.4 starts to act up in the near future!
For reference, I do use Photoshop Elements 2021 and all my Topaz plug-ins work well with it. I have a 2021 iMac 27" with AMD Radeon Pro 5300 4 GB graphics card and I have 128MB RAM so my system should be able to handle all the programs I utilize. Still using OS Big Sur and have not upgraded to Ventura as yet. Thanks again!

@matthew.woodford

​We are releasing v1.5.3 in an hour which has a fix for this crash. Please install it and then switch to using your NVIDIA GPU and it should work as expected now.

​You can get the installer here:
Download

1 Like

Seems to be working well for me so far… normally it would crash essentially constantly - so far in editing quite a few images, nothing yet.

Good job!