New problem with latest Sharpen AI

I just downloaded the latest Sharpen AI as it seemed to have a lot of AI updates over the previous version. Now that its installed i can’t start the program. Two error messages come up about the procedure entry point — cannot be found in dynamic library link.

So what do I do now?? This never happened to me before when updating.

1 Like

I ran into that as well. I had to re-download the installer and have it uninstall and re-install the application to get it to work.

Here’s a link to full windows installer:


I did the advised procedure stated above and the program will now load however the program will not sharpen the photo. You can switch back and forth from the original to the processed version and there is no difference

1 Like

The offline installer that links to installs a version that can be opened without the Entry point errors, however if a check for updates is done it brings up a Network error message.

If you haven’t already been bitten by the update, is probably best to decline it until the latest installer/program bugs have been ironed out.

1 Like

Thank you Russell. I assume you will make sure Topaz is working on a fix for this?

I was anxious to see if any improvements were made with the new AI libraries but it seems something went wrong with setting up the new installation.

The in-app updater for windows is now fixed. This was what caused the entry point errors. If you update using the website installer or the offline installer I linked , it will install 1.4.0 and you shouldn’t have problems launching. If you are still on 1.3.x or earlier the in-app updater should work just fine as well.

Sorry for the dumb question, but by chance do you have automatically update preview off? image

Russell, has the Network Error issue that occurred after update with the offline installer also been fixed?

If you are talking about the network error when clicking Check for updates, that is an on-going sporadic issue. We are working to completely change our installers in the near future as this issue and multiple others continue to be an issue

1 Like

That’s the one. Isn’t there a risk of that error preventing getting a further update?
I think I’ll stay with 1.3.1 for the time being.:thinking:

I used the Check for Updates in Sharpen AI today and the update went normal. If you have a slow internet, keep in mind that the download is a bit over 1 Gigabyte in size.

After the news that this was fixed I went ahead and used the full windows installer. Of course it uninstalled the old version, installed the new version and then I was good to go. I went into Lightroom, selected a photo I was working on and had to retell LR to make Sharpen AI an external editor. I was able to run SAI saved my photo and then went to a second photo. This time SAI would not start up. I closed LR and tried to start SAI directly - it still would not start. I looked in the Program Files folder where SAI was installed and the exe file was no longer there. Not only that but the installer I had just downloaded was also eliminated from my downloads folder.

So what is going here??? I’m not sure all the bugs are worked out. Do I just redownload the installer again. Is anyone else seeing weird behavior when calling SAI from LR?

Perhaps your anti-virus as placed it in quarantine?

Interesting thought. Can I recover this from quarantine? It would do this after I used the program once - even when I told Windows to go ahead and install this program? Or should I just uninstall and reinstall turning off antivirus software?

If it’s in quarantine you should be able to recover it, and then add it to the white-list of programs to ignore.

I re-downloaded as you suggested and it is still a problem. The colors are terrible and the crop is different than the photo I opened. Your company had excellent plugins in the beginning but things started deteriorating when they started adding new programs that were not ready for the marketplace.

I tried to update Sharpen AI 1.4.3 to the newer version but the update fails. After the “Updates Available” dialog, nothing will happen. I am running on MacOS 10.13.6. Is there a direct download for this update for MacOS as well?

Have you thought about going to > downloads?