New installation, all Topaz products crash upon launch

I bought the suite of Topaz photo products a while back during a sale. I finally tried to install and use them for a project this week. So far I have been unable to even get the programs to launch. When I try to start any of them (also tried “run as administrator”) I just get an immediate crash report.

ThinkPad P51
Xeon E3-1505M 3.0Ghz
Intel HD P630 / Nvidia Quadro M2200
all of the Topaz apps are set to use the M2200, driver (latest available)
Windows 7 Pro 64-bit

I downloaded and installed the versions that were listed for Windows 7:

DeNoise 3.3.4
Gigapixel 5.8.0
Sharpen 3.3.6

Trying to open any of them results in an immediate crash report. Trying to use any of them inside Lightroom Classic results in the same crash.

Problem signature:
Problem Event Name: APPCRASH
Application Name: Topaz DeNoise AI.exe
Application Version:
Application Timestamp: 6176bd77
Fault Module Name: ntdll.dll
Fault Module Version: 6.1.7601.24545
Fault Module Timestamp: 5e0eb67f
Exception Code: c0000005
Exception Offset: 0000000000027a6d
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: ad48
Additional Information 2: ad483e447d9e2867fe747a9f8c014e97
Additional Information 3: 17de
Additional Information 4: 17ded42682849a25c0e0099266199a10

When I close the crash report, I get another error message:

The application was unable to start correctly (0xc0000005). Click OK to close the application.