New 3.0.3 update writes wrong time stamp in new processed files

Updated to 3.0.3 and now whenever I export back into Lightroom Classic, the new edited file gets created and stacked correctly with the original BUT the time stamp on the new file is no longer the same time stamp as the original RAW file, which was the case in all prior updates. This is broken now, the time stamp should be the same between the original so that when they get unstacked, they are found together when sorting by time stamp.

Steps to reproduce issue:

  1. In Lightroom Classic, select a photo
  2. Edit Menu → Plugin Extras → Process with Photo AI (using a copy of the original, not overwrite the original)
  3. In PhotoAI do the process and export back into Lightroom
  4. In Lightroom look at capture time for new exported file from PhotoAI, it has a timestamp of when this new file was created, not the original RAW’s timestamp.

Topaz Photo AI v3.0.3 on Mac. Using Lightroom Classic.

Just tested this in LR. The time stamps for when the raw file was shot are still the same time in 2018 in the dng returned by TPAI. Are yours coming back different?

Thanks, yeah, mine are coming back with a different time stamp. The new file created by Topaz just has the file creation date (time when Topaz wrote the file to disk) instead of taking the time stamp from my original picture’s. I have to manually “Edit capture time” in the new file created by Topaz and match it against the original RAW, painful. I’m on Mac OS Sonoma 14.5.
PS: I also tried this on another mac where I’m running the exact same OS and software, and get the same problem.

Any update on this?

Same problem with 3.0.4. Would appreciate some news on this. Thanks.

Another user on the forum is having the same problem with Pentax dng files on Win11. What raw format(s) are you using?

EDIT: I’ve been able to replicate this behaviour with a Pentax dng file (and subsequently a Leica dng file):

1 Like

I’m using Photo AI 3.0.4 from inside Lightroom on Windows 11.

How to reproduce:

  1. Select a DNG file in Lightroom.
  2. Launch Photo AI 3.0.4 from Lightroom by menu → File → Plugin Extras
  3. Select “Edit a copy”.
  4. Denoise/sharpen in Photo AI and save.
  5. Save.
  6. In Lightroom, the newly saved DNG file doesn’t have the “Date Time Original” as well as “Date Time Digitized” field, and has an updated “Date Time” field that is the same as the time it was processed by Photo AI. Lightroom fails to properly sort the pictures using the capture date/time for example.

Using ExifTool, I can see that DNG files saved by Photo AI 3.0.4 have neither DateTimeOriginal tag nor CreateDate tag, the latter is supposed to be DateTimeOriginal. The original DNGs, which was shot by Pentax K-3III, have both. Please preserve these (see e.g. Appendix E.3.4 of Exif version 2.3 specification).

If DNG files and/or system information are needed, please ask.

In the attached, the first screen shot is the original DNG and the second is the DNG saved by Photo AI, both viewed in Lightroom.
Screenshot 2024-06-15 135917
Screenshot 2024-06-15 135905

This seems to be a duplicate of New 3.0.3 update writes wrong time stamp in new processed files.

It’s the same problem, yes. I’m using CRAW format from a Canon R6 Mark II

One minor correction: CreateDate tag is supposed to be DateTimeDigitized, not DateTimeOriginal. Sorry for confusion.