Mutiple issues with latest release - Sep 2023

The last two releases have not worked at all.

The updates failed to install stating a folder permission error. I uninstalled from both PCs and did a fresh install.

Now the save window is showing messed-up text and the system freezes after a couple of saves, then crashes.

The issue is the very same on both machines

2023-09-15-16-40-44.tzlog (391.4 KB)

Steps to reproduce issue:

  1. Step 1 - Open Images
  2. Step 2 - Apply tools/Models
  3. Step 3 - Save Files

Topaz Photo AI v2.0.1 on Windows

Please visit this page, select your operating system (Windows) and click “Find Your System Profile”. Send me the system profile so I can check your system specs.
Topaz Photo AI System Requirements

Where are you installing Topaz Photo AI to? Is it the default location on the C: drive or somewhere else?

What was the folder permission error that you were seeing before?

Hi Lingyu

This is not a machine-related issue, I have two machines, both very high-spec Asus Tuf Gaming Laptop/Custom Built Graphic Design Desktop, Both running Windows 11 Pro.

Both PCs had identical issues, at first neither would download and install updates,

I then removed and did fresh installs on both machines, The install worked but the problems I outlined are identical on both i.e. crashing on save images, and text not displaying correctly on the UI.

I do not have a working copy on any machine currently.

installs were all done normally to C: drive

If this were a widespread issue then I would expect to see many other reports of it. It would help to see your system profile to check what exactly the cause could be.

Are your graphics drivers up to date?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.