Must process twice in AI - SOLVED MYSELF

Recently I have to process each image twice with using the Lightroom Classic plug-in. I use the Photo-> Edit in-> Topaz AI, Edit a copy with Lightroom adjustments (which is doesn’t, it just takes the original TIFF). It processes the image and says it saves it, but it doesn’t (it also doesn’t add the -2 to the filename it says it’s saving). AI closes out, goes back to Lightroom and there’s only the original file. I repeat the process only this time it saves it with the -2 suffix and then there is the AI processed file.

Steps to reproduce issue:
From LIghtroom Classic

  1. Photo → Edit In → Topaz AI
  2. Edit a copy with Lightroom Adjustments
  3. Let AI process the images
  4. Save image to Adobe Lightroom Classic

Topaz Photo AI [v2.3.1] on [Mac], Sonoma 14.2.1

Just found this. What does this mean and how else do we move from a Lightroom Classic workflow without using the “Edit In” feature?

SOLVED! Finally found this (screenshot below). The “external editor plugin” has worked since I started using the product (before they merged into AI) and now suddenly it stopped and I have to get to the tool through a different path. Don’t know if this was Topaz that caused it or Lightroom but at least I found the solution.

1 Like

Awesome! I’m glad that you were able to work through this.

If you ever need support in the future you can reach out to us here or using the following link:

Topaz Labs | Support Page