Model downloading is broken since v5.1.3 but likely server related

I’m getting AI errors so I tried to download the models to make sure that isn’t the problem.

It seems it is, if I use the Model Manager it will go for a while then suddenly throw “Error: Connection handling canceled”. If I try again it will download some more than throw the error again.

I’ve tried with two different broadband connections.

It seems at random the connection will fail, and rather than retrying it just bails, requiring me to manually resume the download. My guess would be this is an issue with the model server.

It doesn’t seem to log this, but I did notice this after running the benchmark which errors out on multiple models:

2024-06-15 21:26:20 23812  INFO:  RESULT for https://veai-models.topazlabs.com/aiob-v1-fp16-ox.tz is Failed to read connection
2024-06-15 21:26:20 23812  CRITICAL:  Attempt 0 failed for https://veai-models.topazlabs.com/aiob-v1-fp16-ox.tz
2024-06-15 21-26-22.913 Thread: 22284 Info FF Process Output: 19 
2024-06-15 21:26:22 23812  INFO:  RESULT for https://veai-models.topazlabs.com/aiob-v1-fp16-ox.tz is 200
2024-06-15 21:26:22 23812  CRITICAL:  Compressed Buffer for aiob-v1-fp16-ox.tz is invalid: 
2024-06-15 21-26-24.614 Thread: 22284 Info FF EXITED: 19 -1073741819 1
2024-06-15 21-26-24.616 Thread: 22284 Info ~TProcess(): destroyed

I’ve yet to see a downloading models error or issue that wasn’t caused by the user’s system configuration/firewall/VPN/antivirus/network configuration.

Suggestions:

Try it with and without this setting:

image

Also, disable any VPN, firewall, antivirus etc. and do some further testing until you find the fault.

The topaz servers are up and I don’t have any issues downloading any models.

This is really weird, nothing has changed on this system or my network (except I put the 4090 back in now I tested my replaced 5950X is stable). Everything else works fine, I even tried the on-board NIC rather than the known problematic ASUS XG-C100C (which seems to be fixed now).

I have no security software installed beyond what Windows comes with. I did have NordVPN but wasn’t using it, removed it and anything else I don’t need just to check.

Its still failing even with a complete uninstall/reinstall of the application. I checked on my backup box and its not suffering the same issue. The only difference is the other box has not yet had 2024-06 Cumulative Update for Windows 11 Version 23H2 applied. Please don’t let it be that, so sick of Microsoft breaking things.

Can we have a feature complete Linux version already to solve these stupid issues?

Can you DL the model directly with your browser on the box with the issue?

https://veai-models.topazlabs.com/aiob-v1-fp16-ox.tz

Yes. They also all downloaded fine so long as I kept going back to the Model Manager and trying again. It seemed completely random.

When I’ve had Topaz model downloads drop in the past, it has always been with wifi connections to the router. Wired connections have always worked better for me.

1 Like

I work as a network analyst for a living and concur that Wi-Fi should only be used as a last resort! :grin:

You reminded me, as I switched network cards I never changed it back to Private Network. Honestly on a private network I usually turn off the Windows firewall and I didn’t check if that is the difference on the working machine.

I never use WiFi for physically static machines and testing my laptop wired would always be the first thing to try if it had problems like this.

Were you able to finally download all the models?

Only be repeatedly asking it to until it finished. Once I turned off downloading of older models, this was less painful.