Missing Export and Save Option | Windows Machine

when i go to save an image after processing it and select save in the drop-down menu it shows the new file name and where to save it but does not allow the actual save. no button of selection to proceed with actuals save


Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please take a screen recording of this behavior so I can see exactly what is happening.

Loom is a great free application for this: Loom | Free Screen & Video Recording

John,

Topaz was working fine until the latest update. It seems to be behaving as a trial version. I took some screenshots. Loom confused me somewhat.

Screenshot 2024-06-23 145059

Screenshot 2024-06-23 150220

Screenshot 2024-06-23 150425

Screenshot 2024-06-23 150656

Regards

Edward Land

Screenshot 2024-06-23 150220.png

Have had no further reply. This is getting frustrating.

This seems to be an issue with the display settings of your application. I’d like to see if clearing your registry entries for Topaz Photo AI would resolve this issue you are having with your Windows display. Please follow the directions below on how to perform this task:

After doing this, please try updating to the most recent version by using the following link:

Topaz Photo AI | Windows Installer

Hi John,

I tried that already, and reinstalled. Made no difference. However we played with display settings as advised by your group and that worked.

Regards

Edward Land

Awesome! I’m glad that our team was able to help with the problem :slight_smile: I have included a link to the Loom video below that helped with this issue so if others have this problem the information will be there for them to review.

1 Like