Mask AI will not register purchased version

I have ReMask, and use it a lot. When Mask AI first came out, I installed the trial. I subsequently purchased it a couple of days ago, and finally got around to installing it today.

First, I fired up the trial version (18 days left in trial), and tried the Help > Update Product Ownership, which I would assume is the path to registration. However, nothing happens.

Since that did not work, I downloaded a fresh copy of 1.0.3 and installed it. It first uninstalled the older version then installed itself. When I started the newly installed 1.0.3, I still get an “18 days left in trial” in the header, and again, selecting Help > Update Product Ownership does nothing.

Note near the end of the installation process, I kept getting a popup window that another version of the installer was running. I only started one instance, but the popup kept appearing even when I closed it down, finished the install process, and started Mask AI.

I restarted the system and that seemed to clear the insidious popup, but it did not fix the Update Product Ownership issue.

So … my question … how do I register my purchased copy? It appears on my product ownership list, I have the order & invoice from the transaction, but it seems that I cannot get out of trial mode.

Note also that the recent update for Studio 2 caused the same popup to appear, and it kept appearing until I uninstalled the previous version, installed the new version, and restarted the system. What’s going on, Topaz? Lots of quality issues starting to surface in your products.

I’m running Win 10 (latest update), Nvidia M1000M (latest driver), 40GB RAM, 2.25TB drive space.

I don’t recall the specifics, but I think you need to go into your account and download it from your purchased download not from the general one.

You need to login which I believe is under the Community or Help menu.

Thank you, AiDon. You are correct. Thanks.

In the Community menu is a function called “Switch Users” … now, who would have guessed that first of all, it really means “Log On” for the first time, and secondly, that, unlike virtually every other product out there, where product registration is not under the Help menu, a user has to go to “Community” to register?

Could Topaz be any more obscure about something as simple as license registration? What other useful functions have they hidden behind cryptic function names? Only time will tell.

And what the heck does “Update Product Registration” do, anyways?

It saddens me to say that the once-great Topaz Labs appears to be screwing the pooch on this one.