Mask AI useful?

Hi there

My problems are:

  1. If you don’t create a mask in phtoshop prior to using mask ai you will get no mask out of the Topaz plugin.
  2. Topaz Mask AI without the very good functioning transparency tools of remask 5 is not useable in cases with transparencies. The new tool of Photoshop 2020 is much better and about 19 times faster than Topaz Mask AI. Where is the AI? Does the Topaz tool is improved in future?
    In the moment I am heavy disappointed about the Mask AI tool because it so much worse than Remask 5 and i spend money for that. There are lot of things to be improved in the future. I hope it will. Topaz tools were very good up to now.

Best regards
Harry

I would say you’re lucky to have both, Mask AI is still work in progress and we, as a user base, are sure there are updates coming.

See if watching the webinar helps…

https://community.topazlabs.com/t/webinar-mastering-masking-in-mask-ai/12372/5

1 Like

With the new release of Photoshop 2020, which have absolutely sensational cut tool (the new background remover with very precise cuts, almost as in vectors), Mask AI becomes useless if it does not come with something absolutely revolutionary!

Mask AI should be able to do at least what Photoshop 2020 can do, but much easier and faster! In other words, Mask AI could be a cutting tool like in Photoshop 2020 but for dumb people and for hurried people.

The Object selection tool in PS works on simple shapes. It’s totally useless on anything complex. On DPreview there are a number of posts of people testing various masking products. Mask AI works in some use cases, not well in others. For complex cutouts - say a portrait of a person with a lot of fly away hair, it is impossible to get a clean cutout against a dark background. Too many halos. You can reduce the halos using the edge refinement tools but you can’t eliminate them entirely. The cutouts look a lot better against light backgrounds where the halos are not as visible. Also you pretty much have to switch to contrast mode to fix some edges because refining with the red and green brushes in AI mode is too painfully slow. On some subjects like cars at car shows the output from compute is so rough and jagged that it is unusable. I end up falling back to Remark 5 which has far superior edge refinement tools. Right now Mask Ai is a mixed bag. It works in some cases, not in others. But it is far superior to the Object selection tool in PS

Problem is simply that the base layer is locked. Unlock it or duplicate the base layer which creates an unlocked layer and it works perfectly.

Also add a blank mask to the layer before passing it to Mask AI.

I am so fed up with Mask AI. It will not open after updating to Version 1.0.3. I have uninstalled it and called American Express and disputed the charge of $49.99 for the program. AmEx has taken the charge off of my bill until they hear from Topaz. They started out as a nice company with some nice products but now they have slipped. Not sure if I wll ever purchase a Topaz product again. They have no support for their products. A phone number would be nice. Even Adobe has that.

You really need to raise a support request as this is a user to user forum. It seems you are the only person that has reported an issue here with the update no longer opening … and, we have nothing to do with Amex here.

I hear what you are saying, but this is the only place I can find to vent. As I said I get no response from tec support. We are a professional photography studio and need a quicker response than a few weeks later. It’s OK I have Remask 5 and it works fine for me. I doubt I will ever but another Topaz product again. I also hear what you are saying that I am the only one with the problem, but Topaz has not been helpful in helping me resolve it. At least Adobe is helpful with this kind of problem. Very unhappy!

I have made upgrade from Mask AI 1.0.2 and noticed that it has been updated directly to version 1.0.4, which version is no longer working! After upload the picture, and I selected the edges and when I start to process the image, the Mask Ai 1.0.4 program crashing! Not working at all!!!

LATER EDIT: It’s working only if I select the “Contrast” mode! If I select “AI” mode, not working at all!!!

In the file->preference->advanced preference, can you try different options GPU/CPU, and Optimization On/Off? Probably, the new GPU optimization is not working on your machine.

@partha.acharjee, THANK YOU! It was CPU mode selected by default after install (on previos version it was set on GPU mode). I set to GPU + GPU optimization and now it’s working. Thank you!

Can you do me a favor? Just reset from the Advanced Preference and see which option get selected in your machine, and see if you see the crash for the auto selected option.

@partha.acharjee, I clicked the “Reset” button, then I closed the Mask Ai program and opened it again. I noticed that it kept the settings on the GPU.

But when I updated from 1.0.2 to 1.0.4, it seems to have automatically switched from GPU to CPU.

MY COMPUTER:
Application & Version: Topaz Mask AI Version 1.0.4
Operating System: Windows 7 SP 1 (6.1)
Graphics Hardware: GeForce GTX 970/PCIe/SSE2
OpenGL Driver: 3.3.0 NVIDIA 436.02
CPU RAM: 32654 MB
Video RAM: 4096 MB Total, 3706 MB In Use
Preview Limit: 6276 Pixels

You have to compute a Mask in AI mode. In that case, the program will run a benchmark on all available devices in your machine and choose the best one. Check the setting after computing a Mask.

Now it is a big problem! NO longer works!

Looks like the benchmarking doesn’t work properly in your machine. Please manually set this to GPU + GPU optimization again. It would work again. Thanks for the feedback. We’ll closely look into this issue.

It doesn’t want to work at all!
I manually set GPU + GPU optimization and still does not want to work, the program is crashing!

It was just working before. Strange! What about GPU+Optimization Off?

Used the in app updater to move to 1.0.4. No crashes. Checked and my previous pref of GPU was still there. Tried GPU optimiation, no crashes but the app does not run any quicker than before. But no crashes at all. Win 10 PC with GTX960 with 4GB 4 core with hyperthreading at 4.6Gh and 32GB mem, all SSD.