Lens Model and Lens Serial Number EXIF fields not read from Panasonic .RW2 image files by DeNoise AI

The EXIF metatdata for Lens Model and Lens Serial Number from Panasonic .RW2 image files are not written into the EXIF metadata for the .dng files that DeNoise AI creates and outputs. My workflow starts with a .RW2 file being processed by the DeNoise AI standalone app. The .dng file produced is then processed by the Sharpen AI app. Finally the .DNG is processed by my photo editor, AFFINITY Photo which uses the Lens EXIF metadata for lens profile selection and subsequent lens geometry correction. Unfortunately, the Lens EXIF data is not picked up and written to the .dng file that DeNoise creates from the original .RW2 file. My workarounds are tedious and error prone. The problem appears restricted to my Panasonic .RW2 files. If I begin my workflow with a .jpg, the lens data is correctly processed and reaches my photo editor where it works fine. Are there any plans to fix this annoying bug?

Raise a support request at the main website.

Note also you will need to supply the camera model as not all Panasonic cameras write the same RAW structure.

In the meantime a workaround is to use AP as the RAW editor and DeNoise and Sharpen as plugins to AP.

Thanks for the response. I will try to resubmit the issue as you have suggested.

Ive tried without success to install DeNoise & Sharpen as plugins to AP. I just assumed that they were not designed to work with AP and never investigated the possibility that it could a case of User Error on my part of the install. I willl look into all that now. Thanks again.

AiDon, I’ve tried to follow your advice by using DeNoise & Sharpen as plugins for Affinity Photo. AP will work with Photoshop plugins so in theory the Topaz plugins should work. AP will look for the PS plugins in the PS locations for plugins except that I don’t use PS. AP will also let specify an arbitrary location, but I must be able to place the Topaz plugins in where I tel AP to look. Topaz instructions tell me to look for files that are named …\Topaz Labs LLC\Topaz DeNoise AI and by example …\Topaz Labs LLC\Topaz Sharpen AI and select Package Content for …\PS_Plugins. The revealed components DO NOT show any such files. So what to do?

As you suggested, I also tried raising a support request at the main website. That turns out to be a hit or miss proposition.

I believe if you locate the upper level folder, Topaz Labs LLC, and insert that as the location for other folders in AP it should be OK.

Also I believe that there is a option in the Help Menu to reinstall plugins, try that also.