Latest Update to Sharpen AI (1.1.0) NOT addressing Serious Bugs

The following bugs really need to be addressed and yet we have model releases for Sharpen AI:

  • EXIF is still being stripped
  • Various NVIDIA GPUs causing crash on using the File menu
  • And resource usage issues as seen in this screenshot using SHARPEN .10 .10, just missed the 100% GPU on the page.

1 Like

Hello I’m running win10 SSD/16GB/nivida 1060 card.
I’ve been noticing Incredibly amounts of crashes with easy edits. Topaz literally just quits and cutts off. I have a yoga 720 4K Laptop all my drivers are up to date etc. I also noticed with on1 raw 2019 I’ve been having the same kinda issues really slow results. I use topaz as a stand alone also with on1.

I believe that model also utilises a Intel HD graphics card. Is Sharpen AI using the NVIDIA card? You can check by going to Help-> Graphics info and it will show the GPU you are using.

If not allocate the GPU using the following instructions:

We are hard at work on a heavier update for Sharpen AI. One major focus of which is a revamped approach at metadata to remediate issues you’ve all been seeing with various applications.


I am seeing issues with Sharpen AI used as a plugin from other hosts:

MacOS 10.14.3
Sharpen AI 1.1.0

Standalone works fine.
Called as a plugin from Topaz Studio works fine.
Called as a plugin from Affinity Photo – launches, gets the image, all the UI works, but it does zero processing – the time to update the preview is instantaneous, the returned image is identical to the original. I didn’t see anything glaring in the log files (not that I know what to look for). Using GPU on a 2016 MacBook Pro.

Hi, It is OK on Windows the developers should take note of this @russelltarpley

thank you for your quick response’ I’ve done what you suggested topaz still crashes after a few minor adjustments. I would love to have this working because i’m about to purchase couple add on. Is there a way that someone can screenshare my laptop and guide me in the right direction.

Is there a way to go back to version 1.0.9? Updated to 1.1.0 and it slowed down the processing time. 1.0.9 would take 2 minutes and 30 seconds to apply stabilze to an image. Now the same image takes a little over 3 minutes.

Memory 16G
GPU Radeon RX 570
Memory 8G

You would need to raise a support request at the Need Help link above to see if they have a previous installer available.

1 Like

After latest update Sharpen AI launches (Standalone, from P{hotoshop and Studio) but there is no screen. Shows as process in Activity Monitor. Tried reinstall doesn’t work. Using Mac OS X 10.13.6 Nvidia 1080. Latest Photoshop CC. Should I get a hold of old installer 1.0.9 and revert?

Updated to 1.1.1 and then 1.1.2. The issue with the plugin not working from another image host (Affinity Photo) on MacOS is still there.


Can you raise a support request at the Need Help? Studio link above and then choose Open A Request, Need Help for my product and choose Sharpen AI from the drop-down list of Which product can we help you with.

I don’t have any issues on Windows 10 with Affinity Photo and Sharpen AI and the only thing I can think of is that under Affinity’s Performance preferences make sure that it is using the GPU as a renderer and that Retina Rendering is set to Automatic (Best).

Sharpen AI 1.1.2 Mac version is stripping exif data from my files. This behavior is not acceptable and if not corrected soon I will ask for a refund.

The issue with metadata and other file input/output items are actively being worked on for the next major update. That update is currently scheduled for early May.

1 Like


I hope that also the issue of not being able to open TIFFs that have ZIP compression, will be addresed.

For example, Capture One Pro outputs ZIP compressed TIFFs and I first need to open and resave those files with LZH compression (or no compression) using Photohop before I can apply sharpening to the individual files.


Why don’t you just Edit With with no compression from ON1 Photo RAW?

Sharpen AI 1.1.3 (just purchased) is stripping EXIF data. Very annoying as order of images changes in Lightroom when used.
Please resolve ASAP.

It is a known issue and in the works. Topic closed.

1 Like