Latest DeNoise doesn't remember screen size/location

The latest upgrade of Topaz’s DeNoise program messed up its ability to remember the screen size and position that I used last time. This didn’t happen with prior updates, only the latest. Any idea how to clear/reset this?

Launching from Windows. Running at 100% on a 43" 4K monitor.

1 Like

Since updating to 3.2 and now 3.3 Denoise opens in a small window. Previously it always opened maximized. I can find no way to force it to open maximized like it used to. Sharpen still opens maximized, as well as Gigapixel. Only Denoise took on this behavior after updating.

When I open it as a plugin from Lightroom, it opens in a small window, and can’t be maximized until after it renders the preview. This behavior is the same even when I open it stand alone. Everything else is working great, but opening in a small window is really starting to bug me, badly.

Someone please help me to fix this! I’ve tried several times opening it, then dragging it to the largest size possible to fill the monitor, then clicking the maximize icon, but it won’t stay. Every other windows program retains the maximized size when I do that, and Denoise did it too, before the last 2 updates. I really need to get this sorted out.

Any help is appreciated, thanks!


I was about to post exactly the same issue. It’s so annoying and slows the workflow. It needs to be fixed.

1 Like

This has been reported by several people in the DeNoise release thread. One of the devs explained:

“This is a temporary measure since some users were unable to open the application at all due to issues with window position/size saving.”

It should be fixed in the next release.

1 Like

Thanks for the reply Paul. I really don’t want to wait until the next release though, I would like to get this fixed now. Not next week, next month, or several months from now for it to be fixed in the “next release”, unless of course that “next release” is coming out tomorrow.

I just wonder if there is something that could be changed in the registry or something like that that would force it to open maximized?

You must be psychic - new version just released!

Just installed that, and now it’s opening maximized!

1 Like