Just like in DeNoise, PhotoAI still just creates frustrating and frankly stupid artefacts

I use DeNoise AI frequently but get frustrated with it creating extra work through “enhancing” or outright creating chromatic aberration (coloured edges) and adding bright pixels, effectively creating noise which is the opposite of it’s prime function, and finally, occasionally creating bursts of outrageous colour artefact. So since Topaz haven’t updated DeNoise in over a year I hoped PhotoAi would be the future, but it’s mostly just as bad. I know I can change the settings but what on Earth can justify this abomination (attached).

Steps to reproduce issue:

  1. Step 1 Load RAW file
  2. Step 2 See default results, change de-noise to strong
  3. Step 3 Watch the bizarre colour generation, which cannot possibly be considered to be improving an image

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Seeing same with default ‘autopilot’ settings here -

If I simply increase “strength” from 1 to 2, the pink goes away.

There are a few issues you have described which we are working on.

  1. Hot pixels, we will be improving our Raw handling for this.
  2. Raw Remove Noise model artifacts, we are updating the Raw Remove Noise models soon to prevent this.

If you have this file on hand, I can reproduce it with the Raw and share with my team so we can prevent this artifact.

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Why have you hidden my post and flagged it as marketing spam, it’s just a complaint.

Hi Lingyu (apologies for the earlier typo),

I’m confused, I’ve had an email saying that my post about the flaws in PhotoAI has been hidden as it is SPAM and a marketing email. It really is not so this just looks like Topaz are hiding negative topics.

Also, I thought you were replying to an email I sent regarding this problem and more but I now see that the email was unreceived. Topaz really don’t like feedback any more do they?


The system flagged that you tried to create multiple posts with links to the same domain. That means you tried to create other posts linking to this thread.

If not so please confirm that so the spam threshold in the system can be reviewed.


I’m not really sure what I did, there’s only 1 post isn’t there? What other post did I make linking to this? I really don’t understand what’s meant to have happened.


I’m not sure what you are describing as neither any admin I know nor myself has blocked any posts recently.

What was the content of your post or message? It may have triggered an automatic moderation step.

You may have received an email about my reply. All responses should be sent here on the forums. Did you try responding to the email?

It seems there was a link to the post itself … nothing was blocked.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.