JPG Pictures not loading

My workflow is based on JPG images.
Ever since V 1.4, the old saved pictures (before today, when I updated the Photo AI) will open, but none of the pictures saved after updating won’t open on Topaz Photo AI.

Everything is the same as it was yesterday with the older version, no changes made to my Preferences.

Any clues? Should I open a ticket with the Help Desk instead?
Thank you!

1 Like

I just tested it on my system and they save and reopen in 1.4 with no issues.


Thanks for checking. The problem I encountered is with JPG already saved from a third program (Nikon NXStudio) in JPG. Once saved as JPG, when trying to open it with Photo AI, it freezes and won’t open.

I guess your workflow or test was different, maybe you are using a different program to edit/save? And have integrated Photo AI within the program (as a plug-in)?

No other program involved, just native TPAI.

I might have not explained myself: did you open a JPG already saved and edited with a different program or you used TPAI to save the RAW in JPG ?

If no other program is involved, your experience does not matches mine or my problem with the latest version. In other words, I’m sure it works for many, what I’m trying to find out is if it works using the same workflow I’m using (and was using until this latest upgrade):

  1. NEF file edited using NX-Studio
  2. Saved as JPG on the HDD
  3. Open Topaz AI and load the JPG = fail.

How old is your NX-Studio … i.e. is it the latest version?

1 Like

Latest version, 1.4.0 64bit.

FWIW: I have since uninstalled the AI and reinstalled an older version and zero problems.

Ok, just let support pick this up. They should get it today.

1 Like

It was already a jpg that I edited for Text Enhancement and Enlargement in TPAI. Closed and reopened in TPAI for additional editing just fine.

1 Like

@marcelo.cinicola Thanks for reporting this.

The NEF converted JPGs not loading is a known issue we’re working on fixing. I expect it to be solved within the next few releases. For now, I recommend processing the NEF in Photo AI prior to editing in NX-Studio.

We appreciate your patience and understanding as we get this fixed for you.

1 Like

Thanks for the update Tim. Meanwhile, I’m using an older version of TAI instead. As for your suggestion, my workflow has been the same for years, so I rather wait for a fix to it than making not needed changes on my workflow. Will we hear back once this issue is gone?

Could you share one of the converted JPG files so I can test it?

You can securely submit your image(s) to my Dropbox using the link below. Please be sure to send me a note to let me know you sent something.
Dropbox File Request

Thank you! I’ve sent thru the Dropbox link one of the files that were not opening in V 1.4 .

I was able to open this file without issue. Please check the file path for special characters like “?” as they can prevent Topaz Photo AI from opening the file.

Where are these files stored? Does Topaz Photo AI have access to the location?

I believe I might have sent you the wrong file, yet, the file path for ALL my pictures are the same, without any special characters or funky looking names. All files are stored in 2 external HDD that works perfectly when using any of the former versions of TPAI. My workflow has been and still is the same, and as I mentioned before, there were never any issues while using any Topaz product (and still works fine with former versions).
I’ve read above that the issue is (was?) well known and Topaz was working on a fixing, expected to be solved in a next release.
I’ll try again to install the latest version and revert, since these problems were related to v4.0 and now we are at v4.2, so this issue might be dated now?


Just installed the latest TPAI v4.2 (didn’t bother with 4.1) and now it works flawlessly, no issues whatsoever.
It works as it used to (prior to me installing v4.0) only that seems to be running faster than before.

One question remains: is there any way to get the interface to NOT show the “recent files” by default?
Thanks for the support Lingyu!

At the moment there is not a feature to remove the recent files. Why do you need this?

I believe it could be optional, I personally do not need this feature shown as permanent. No big deal, just asking if there was a way to switch it on/off that I was missing. On former versions this wasn’t shown as standard. Thanks anyway Lingyu, my main issue is solved you you might as well close this thread.

Got it. We added it as a feature in v1.4.0 so it did not exist in v1.0-1.3.

Let me know if you need anything else!

1 Like

Thank you again Lingyu, for the time being I’m all set. Cheers!