JPEG to RAW AI - won't save output image

When trying to convert jpg images to raw, the display shows 100% processing and then I get the message "Error: Failed to save file [filename here]
I have tried various changes in Preferences, memory consumption mode from medium to low, GPU to CPU, run in background to no run in background, .dng, .tif, .tiff, but none of the alterations have made any difference. I’ve even tried obtaining and saving from/to different drives. The output file still won’t save.
I’ve tried all the suggestions of Topaz Tech Support, and the output file still won’t save. They say they can’t replicate the error.
Can anyone tell from the info below what might be causing my problem?
Thank you!

Here is my info from Help > Graphic Info:
Application & Version: Topaz JPEG to RAW AI Version 2.2.1

Operating System: Windows 10 (10.0)

Graphics Hardware: GeForce GTX 745/PCIe/SSE2

OpenGL Driver: 3.3.0 NVIDIA 451.67

CPU RAM: 16322 MB

Video RAM: 4096 MB Total, 3538 MB In Use

Preview Limit: 6115 Pixels

And here’s the info from the error accessed via the Event Viewer (if I did it right):
Log Name: Application
Source: ESENT
Date: 7/14/2020 11:50:53 AM
Event ID: 455
Task Category: Logging/Recovery
Level: Error
Keywords: Classic
User: N/A
Computer: DESKTOP-L3HFI55
svchost (15572,R,98) TILEREPOSITORYS-1-5-18: Error -1023 (0xfffffc01) occurred while opening logfile C:\WINDOWS\system32\config\systemprofile\AppData\Local\TileDataLayer\Database\EDB.log.
Event Xml:



-1023 (0xfffffc01)

That doesn’t seem to be a JPEG to RAW error message.

Try the following:

  • Try running as Administrator, either right-click on the Icon and select Run as administrator, or switch to a Admin ID. Note that Windows 10 recommends that ALL applications are installed as admin.

I right-clicked on the Icon on my Desktop and selected Run as administrator. Same thing happened: the image didn’t save.
As far as I know, I am the administrator, so what do you mean by switch to a Admin ID?
Thanks, Karen

Switching to Admin ID only if your user ID isn’t admin.

OK, a couple of things here:

  • GPU/Medium memory usage should be the best for you. I have seen more issues coming up with the GeForce GTX 745 as it is a older GPU but it shouldn’t stop saving the image, only be a bit slower.
  • I take it there is plenty of disk space available on your C: drive as that is where the Local AppData is held and any temp processing files are created.
  • Also I guess you use similar settings to mine here, a 6000 x 4000 JPG, where the TIF output is processed and saved within 9 seconds. I use a NVIDIA GTX1050/4GB which is similar to your GPU.


So now can you go to Help-> File Logging and make sure it is on, if it says Off just click and it will turn it on, and the Menu will show File Logging: On.


Run a image through again and post a screenshot of your settings for the output file, then type this in the explorer search bar, without the quotes, “%localappdata%\Topaz Labs\Topaz JPEG to RAW AI\Logs” press enter and upload any files there by appending .txt to the end of the name. For example, “2019-11-17-09-49-40-Main.tzlog” would become “2019-11-17-09-49-40-Main.tzlog.txt”

We will see if we can find a reason.

Here’s the screenshot followed by the log file:
2020-07-15-09-56-58-Main.tzlog.txt (24.9 KB)
Thanks much,
Oops, I just noticed that the Output settings aren’t showing up in the screenshot, so here is another attempt at the screenshot.OutputonlyScreenshot7-15-20

Hi, I will have a look at that soon but, in the meantime, please go to your Desktop folder (the one you are saving to) and right click then select Properties and click on the Security Tab and confirm that your current user ID has Full Control. (In your Case “C:\Users\kford\Desktop\jpg2raw”)

Please run the application again with that JPG, select the original folder where you opened the image as the Save to location, change the Suffix to “J2R” rather than “jpg2raw” as that may be a conflict as the Desktop location you are saving to has that folder name.

1 Like

OK after reading the Log there are some things you can check:

  • Is the file “C:/Users/kford/Desktop/jpg2raw/IMG_1038 copyjpg2raw.tif” on your PC?
  • Move that input image to the local disk (“I:/Photos from Phone/2019-07/IMG_1038 copy.jpg”) and then try again

It appears that my current user ID has Full Control. When I click on properties for the jpg2raw folder, “C:\Users\kford\Desktop\”
I changed the suffix to J2R but the file still didn’t save.
No, the file file “C:/Users/kford/Desktop/jpg2raw/IMG_1038 copyjpg2raw.tif” is not on my pc. And I moved the input image (“I:/Photos from Phone/2019-07/IMG_1038 copy.jpg”) from the I external drive to “C:\Users\kford\Pictures\Photos from Phone\2019-07/” and ran the program again, but the file still didn’t save.
I think there may be some kind of problem with my pc possibly caused by some diagnostic software run by a Best Buy Geek Squad “techie” from India that I was talking to by phone a few weeks ago. Since then every time I restart my pc, I have to reapply my settings for my trackball mouse in order to be able to right click. I think I will wipe my pc clean and reset or reinstall Windows 10 and see if that helps. If after that I still can’t get JPEG to RAW AI to save the output file, I’ll check back in with you and see if you have anymore ideas. It may take me several days to back up everything important, reformat the hard drive, and reload all the software.
I thank you for your time, persistence, and help, kind sir,

1 Like

I am having the same problem saving files on my iMac using the program. The JPEG to RAW worked on some JPEGs when I started using it, but after a few conversions, I started getting the same output as you. I thought at first it may have been an external drive, but that proved not to be the case. So I moved the files to my desktop and ended up with the same results; “error Failed to Save File”. Why it would work and then start to fail may be a problem within the program?

Ben Balmaceda with Topaz Labs just suggested that my antivirus might be causing problems, so I temporarily closed Trend Micro and Malwarebytes, and WOW success! The file finally saved as a .jpg. So you might try looking at that. If not follow all the suggestions that AiDon had me try and one of those might work for you!
Good Luck!

1 Like

The Same here on IMac.

After reading several boards I found the issue. Seems the UI does not follow typical standards. Even though the format says “DNG”. That does not mean DNG is selected.

You must select the format and have it displayed under the output location box. Silly I know, but that’s how it was coded.

Hi there, I had the same issue with being unable to save the resulting file. I have full admin control over the folders I intend to save to on Windows 10. What worked for me was, to simply move the original file from a folder on my desktop to another folder directly in the root of the hard drive (I called it temp). By doing so, it worked just fine. Hope that helps others strugeling with the same nerving issue.


Simon Formanowski’s solution worked for me. I moved the original from a sub directory to “pictures” in my Windows 10 PC and J2R worked and let me save the image. Perhaps there’s an issue with file name length? Don’t know. Wish Topaz would fix whatever the problem is.

Brand new here. Just adding that the same issue just happened to me on my first go-round. (I’m on Windows 10 Home, 64 bit.) I will try moving my file to a new folder in C drive and actually clicking “dng,” for good measure. But still letting you know this issue exists for others, too.

Yep, that worked. :slight_smile:

I was having this issue as well. I am running this as administrator, selected the output path and selected DNG (has check mark). Running the most current version of Windows 10. The method Simon (Jan 16) mentioned worked. Thanks!

This suggestion worked perfectly for me. Thank God. I am so happy. It was an easy fix and it worked flawlessly.

One question: Why does the Output section say ProPhoto RGB?

That is the most expansive color profile available giving your image the widest gamut of colors available. Others are sRGB and AdobeRGB.