Issues with saving changes back into Apple Photos from PhotoAI 1.5

Anyone else experiencing the following error when saving photos back in to the Apple Photo Library:

"Unable to Save Changes for “Edit in Topaz Photo AI. An error occurred while saving. Please try again later.”.

This only happens when I edit an image using the “Edit in Topaz Photo AI” extension within Apple Photos, and specifically when saving the file in the Photos App. The problem also seems to be specific to Photos taken with the iPhone as it seems to work okay with photos taken from my DSLR.

Steps to reproduce issue:

  1. Load up Apple Photos, select an iPhone image and click edit.
  2. Select the 3 dots and choose the option Edit in Topaz Photo AI
  3. Use Photo AI - make whatever changes you like and then click save.
  4. Once control returns to Apple Photos select Save and this is when the error occurs - (See attachment).

Topaz Photo AI v1.5.0 on Mac

Macbook Pro M1 running latest version of Ventura; Apple 14 Pro Max running latest version of IOS.

I have rebuilt the Macbook from scratch and still experience the same problem.

Any help would be most appreciated.

I’m getting the same error. Mac M1 16G Ram

Do you have steps for reproducing this error? I have tried but can’t figure out what’s causing it so far.

Do you have antivirus or firewall?

I had this once in the past as well.
But not anymore, so it seems to be quite sporadic.

Normal processing… It ques the image for saving and that process completes. Then Topaz returns with a prompt to “Press save to Commit Changes.”

Screenshot 2023-08-09 at 5.56.59 PM

I’m running a plain jane Mac Mini latest Ventura 16G RAM and NO antivirus or any firewall that doesn’t initialize on a Mac out of the box.

I have a screenshare on Tuesday with a user to try troubleshooting this issue.

Let me know if you find anything about this behavior.

I will

I did quite some images yesterday and randomly got this error again.

I couldn’t find out a specific pattern as to when it happens.
But closing and then restarting Apple Photos mostly resolves this.

Still annoying.

I haven’t been able to discern a pattern. When I think I do, it either fails or doesn’t fail on the next go…

Bob and I did a screenshare today for this. In his case, the images were taken with an iPhone and the orientation was causing an issue with saving.

Rotating the image clockwise or counter-clockwise and then using the plugin allowed the image to save.

For that issue, I made a task for my team to look into.

Please try that. If it doesn’t work, let me know and I can send a link for a screenshare to troubleshoot the issue.

1 Like

Yup…That’s the issue… Landscape Good, Portrait Bad! Thanks… :smiley: