Interpolation & CLI vs GUI

This might be already addressed in some other topics but as much as I looked for the answer so far, I wasn’t able to find the answer.

I have been running TVAI since I purchased it under MacOS, 12-core, RX 580 8GB VRAM. Not too long ago I discovered that I wasn’t able to run certain new models. So I bit the bullet and purchased a PC. I was lucky enough to find a “beast” on OfferUp with some top-of-the-line specs:

Here are the specs and the benchmark:

Topaz Video AI  v5.0.1
System Information
OS: Windows v11.23
CPU: 13th Gen Intel(R) Core(TM) i9-13900KS  63.715 GB
GPU: NVIDIA GeForce RTX 4090  23.576 GB
Processing Settings
device: 0 vram: 0.8 instances: 1
Input Resolution: 1920x1080
Benchmark Results
Artemis		1X: 	41.55 fps 	2X: 	19.05 fps 	4X: 	04.88 fps 	
Iris		1X: 	37.39 fps 	2X: 	23.07 fps 	4X: 	05.10 fps 	
Proteus		1X: 	39.42 fps 	2X: 	21.64 fps 	4X: 	05.24 fps 	
Gaia		1X: 	15.29 fps 	2X: 	10.44 fps 	4X: 	04.76 fps 	
Nyx		1X: 	17.33 fps 	2X: 	13.49 fps 	
Nyx Fast		1X: 	30.04 fps 	
4X Slowmo		Apollo: 	37.74 fps 	APFast: 	78.49 fps 	Chronos: 	31.69 fps 	CHFast: 	34.10 fps 	
16X Slowmo		Aion: 	31.08 fps 	

Compared to my old rig this is more than 20 times faster and I am also able to run all the models.

Now since I have all these possibilities I started enhancing (again) everything I did so far. At the end of the day, what used to take me 2 days, now it takes me 2-3 hours. I am using normally a 2-pass at the same time, first Iris v2, second Proteus v4. And I just decided to actually increase the framerate for all of them to 60fps.

Here are my issues:

  1. This one might not be relevant to this forum but I hope somebody else has been running in the same problem. Most of time the machine is processing multiple videos in queue without any issues but sometimes while it’s processing only one the display goes blank/black even though the processing continues, so I don’t see anything anymore. The only way I can tell if it’s still running is by looking at the shared folder (from another machine) and I see the file size increasing. But after that I have to do a hard reset of the machine to get control back of the screen. I tried looking at the logs through the Event Viewer but there is nothing consistent: I get some errors on (what seems) is RAM, PCI etc. Obviously this machine is capable to run anything that is thrown at it. I tried moving the 2 sticks of RAM into different slots but it still happens. Does anyone has any idea why this happens?

  2. Interpolation. From your experience what do you recommend?
    a. Enhance (mostly “cleaning”, no upscaling) first, then interpolation to 60 fps?
    b. Interpolation to 60 fps first, then enhancing?
    c. Perform either one of these in one single export (2 enhancements & interpolation) or one by one (enhancements first, and separate interpolation —> or the other way)?

  3. Performance/speed in CLI vs GUI. I noticed that running the interpolation (Chronos v2) through CLI vs GUI, shows that GUI is about 10% faster (not sure if it’s accurate though). While GUI is processing at ~34fps, the CLI is at 30fps. Is it normal? I decided to go through CLI only because I thought that might solve the problem of the black screen. I just finished the first one in about 150 minutes.

  4. CLI queue - Is there a way to queue multiple exports in CLI, having one running after the previous one, not at the same time?

NOTE: I have been (and still am mostly) a Mac user for the last 15 years, using Windows only randomly for some particular apps that are very convenient for me. I bought this PC only for TVAI, and it wasn’t cheap ($3,000) but I am aware that it’s worth about $6,000. So I am a happy camper with my decision.

I would really appreciate your input.

For number 1: Make sure the RAM sticks are in the slots the motherboard says should be populated first. I’ve never had that issue happen, but I’ve never ran a full video with the GUI. Someone else will have to answer that.

Number 2: The best results possible are clean and upscale first, then interpolate. I think that motion is best when interpolating to 2.5 times the current frame rate (23.976 X 2.5 = 59.94). Duplicate Frames Replace must be off. It does not work and never has. It does make motion choppy, if that’s something you want. If you are doing 4K, Aion is the best model. If FHD, Apollo is as good as Aion, but loads faster. There’s a tiling issue with Apollo 4K.

Number 3:
The CLI only reports total average speeds. The GUI reports speeds from the last second or so.

Number 4: The answer is yes, but you have to do the work. I have made a script to automate the process. The fastest way for you to get into it would be to make batch files from the commands generated in the GUI. You would have to set the system environment variables first, either as part of the batch file or permanently.

First of all, I appreciate you taking the time to answer this.

  1. The RAM sticks are positioned correct. Now it’s actually getting worse. Even running with CLI it freezes and generates this error:

I was able to take the screenshot via RealVNC from another computer.

So now I am unable to get anything finalized. I have been trying to do a clean install of the drivers, still the same. I tried GameReady and Studio drivers from NVIDIA, different version, no improvement. Could somebody tell me what version of the drivers they use for the RTX 4090?

  1. Thanks for the input on that, I will take your advice.

  2. A little bit too complicated for me at this point in time, so I’ll stick with either the GUI for multiple exports in queue or terminal one by one. My main concern right now is what is happening. I am getting really concerned that I spent so much money for a machine like this mainly for the GPU and I can’t use it at all.

Any advice would be really appreciated.

537.58 is the last driver version that is stable on my computer. Every driver after that introduces issues that I don’t want to deal with. BUT they should not affect TVAI. So you can try that driver version, but don’t expect it to actually solve anything.

I don’t use the new Windows Terminal app. I use the old command prompt. There are ways to change it to being the default. That’s my only suggestion for how to not getting that particular error.

Yeah, I meant Command Prompt but being a mac user for so long, old habits die hard. :grin:

I will give it a shot with that version of drivers, right now I am running a MemTest86 to make sure the RAM is fine.

By the way, are you using Studio Driver version, or GameReady?

They are the exact same only the studio name gets applied to driver versions that are supposed to be more stable.