Internet Connectivity Error

I’m completely new around here and have just tried for, quite literally, an hour or two or … to update Photo AI which I haven’t yet used. Version 1.2.10 to the latest.

My laptop is Win 11 with Intel Core 11 & a Nvidea graphics card & SSD.
My internet is poor [rural] max 2mbps.

I’m getting different failures at different points which is exasperating as it is taking so very long to set anything up. Without being too much to the point, wherever the problem is, my aim is to be productive in editing without having to master computing.

This is a screen dump of the last error message - but it changes with each stop of the install.

My internet is always connected despite the message.

I’ve wasted at least 3 hours trying to resolve this issue before starting this thread.

My log -
Topaz Photo AI Installer Log.txt (6.5 MB)

I hope that is sufficient info, please ask for more if needed. Any help is very much appreciated.
Many thanks

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:

  1. Step 1
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Hi @r_offer-522486, sorry you’re running into this error! Do you have any anti-virus or anti-malware programs on your system? More often than not, this error can appear due to one of those.

If you’ve just tried to update within the in-app updater, please also try downloading a new copy of the latest version of Topaz Photo AI directly from our Topaz Labs Download Page instead.

Hello and many thanks for your interest & reply.

I’m running the standard Win11 integrated protection, it is said to be good.

I’ve just tried downloading from the site which you suggested - the Topaz Labs Download Page and this seems to be the location which I’ve tried on several occasions. Tonight the download prematurely aborted somewhere between 1/3rd & 1/2 of the way through.

As it takes so much time to keep trying these downloads, with my slow internet connection, would it be more productive for me to stay one download back from the latest version to, hopefully, get better stability?

Many thanks, I appreciate your time and interest in this problem.

Best wishes

@r_offer-522486, it looks like some of the model files are downloading but then the installation fails partway. You could run the installer multiple times until all you have all of them because the ones that are successfully downloaded are there.

Try installing on a stronger internet connection if you can. The good news is you don’t need an internet connection to use Topaz Photo AI- just to install and update.

Hello Tim
Sorry for my delay, I thought I’d replied!
I have tried to use the programme again but now get a processing error [Could not load model, raise a support ticket] and it tells me [in a red box] in the top right-hand corner of the screen that I have 5 updates. When I try to download them I get the same file size as I got when I originally tried to update it from a new install. Certainly using the programme has no effect on the file whatsoever. Adobe Photoshop renders the file with ease. However I can’t compare the results as Photo AI will not work … at all.
I’m presently downloading updates and following all on-screen instructions as directed.
I’ll update as I have any updated info.
Thanks for your interest.
PS - A stronger - presumably faster - connection is not possible I live almost 2 miles from the nearest fibre cabinet! A solid 2mbps is around max for this connection.

Did those updates work?

There was a bug with the v1.2.1 in-app updater that has since been fixed for later versions. You’ll have to use the full installer on the website:

2mbps should still be able to download the files, albeit very slowly. Unfortunately you may just have to run it multiple times to make sure all the model files are downloaded.

Hi Tim

Thanks for your reply. I’m presently stuck in a very slow update loop – Windows 11 is in the middle of major updates at the moment & one package is failing!! ~ I have Adobe Photoshop & Camera Raw waiting too and there are likely to be both Lightroom versions too and then Topaz AI. I wish I was a computer programmer/engineer!

I’ll update as I get the chance to make downloads – often trouble occurs because one update interacts with others who then update again and the cycle continues, seemingly ad infinitum.

Thanks again for your pointers and help, Tim

All the best

Rob Offer


Hello again Tim

I managed to download from the link which you kindly sent in your email. All seems to have completed successfully and the programme is now working! I look forward to trying it out more fully in due course; I’ve just run one shot through at the moment to verify that it’s working.

Thanks again for your help

Best wishes



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.