Installed Topaz AI won't open

I just installed the paid version of Topaz AI but it won’t open - when I click on the shortcut a blank screen pops up and then closes. I previously tried the trial version and it worked fine. My computer specifications are
Processor Intel(R) Core™ i7-3770 CPU @ 3.40GHz 3.40 GHz
Installed RAM 8.00 GB
Device ID CD214197-3A63-4E53-BB9A-A84943155AE6
Product ID 00326-10000-00000-AA004
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

You might like to specify which app you’re using - there isn’t one just called Topaz AI.

Topaz DeNoise AI is the complete name.

There are five current Topaz AI apps - how do you know the OP is referring to Denoise?

Sorry, I’m confused. Both names apply to this app. The OP stated DeNoise. Is there more than one DeNoise?


The OP stated “Topaz AI” twice - no mention whatsoever of DeNoise. All the apps have “Topaz” at the beginning and “AI” at the end so “Topaz AI” is meaningless.

Sorry for the confusion - it is Denoise

1 Like