"Include live preview" option not saved in V3.3.10

I don’t want Live Previews most of the time, but de-selecting it in Preferences is not saved and it reverts to being selected. Additionally, even when VAI is kept open, it also reverts to being “On” in Output Settings each time I load in another source file.

Could you share a screen recording? I cannot recreate this issue on my end.

Oftentimes it is easiest to share a screen recording for issues like this to quickly show me exactly what is happening. I use Loom for screen recordings since this is a free and easy to use app.

Hi Ida,

Thanks for helping with this.

Presently, I’m too busy to make a video but here’s a procedure
to see the problem which is 100% repeatable and was also in v3.3.09.
I’m getting around it by deselecting Live Preview in Output Options
after importing each file.

The files I’m processing are 25fps 720x576 square pixel h.264 mp4’s
with either AC3 or AAC stereo audio. Output from VAI is 1280x720
conversion at about 18fps and /amazing/, but the bug is annoying because
I do my own Previews before proceeding with each file and I need the
full power and space preserved on the ASUS F15 TUF PC I’m using
(Core i7, nVidia 4050, 2 x 1TB WD SSD storage, Win11 Pro, etc.).

To demonstrate Live Preview Setting Bug In V3.3.10

1 Open VAI
2 Open Preferences
3 Select Export
4 Deselect “Include Live Preview for Exports”
5 Hit “Save”
6 Close Preferences
7 Close VAI
8 Goto 1

-OR - If I keep VAI open and import an extra file -
the Live Preview option is selected again both in
Preferences and Output Settings - after EACH file!