Impression in Studio

I own Impression and I’ve gone through all the steps listed in the below help article and I’ve also closed and re-launched TS but Impression is not showing as “blue” in the Adjustment menu and it’s offering me the Try Pro link. What am I missing?

1 Like

Same problem here- had same issue with Clarity in Studio update- account issues on Topaz end- can’t believe it’s happening again!

did you ‘validate plugins’ in the ‘Help’ dropdown?

Yes, validated plug-ins and synced like the above article stated. Impression even shows as an owned plug-in in the Plug-in drop down menu. Thanks for checking.

are you in V 1.2.7? I would completely uninstall and re-install with the latest .exe from the Studio website. Mine works fine in both presets and as Adjustment

Followed directions from this url to Update to Impression in Studio ( have v.1.19 signed into Topaz Studio account, validated plugins and nothing appears for Impression-http://web.topazlabs.com/2017/09/updating-to-impression-in-studio/

Had the same problem with Clarity in Studio update- was fixed by Topaz, some kind of account issue- many users posting on Facebook same problem with Impression. Clarity fix from HeathRobinson on 9/1/2017 his reply-

HeathRobinsonThis user is a moderatorContent Marketing Specialist
19d

“Rondo, got this fixed for you and found an issue with missing information in the database. Your account is fixed, you should be able to login and click validate plugins and it will work correctly. We’ll be fixing this bug for others shortly. Good find.”

So same thing is happening again- if you want people to use Studio you need to fix this!

current version is 1.2.7

Yes, I’m in version 1.2.7.

Just uninstalled and re-installed and Impression in the Adjustment menu is still not blue. Must be something on the back end that requires @HeathRobinson or @JoeFedric-TL’s magic touch.

Hi Kathy,

Were you logged into your Studio account when you validated? I almost forgot that part. Things went very smoothly for me this time.

Best regards

1 Like

Don’t know about Kathy, but I’m logged in. They fixed it last time, and I still have Clarity. But not Impression. I have the entire suite of plug-ins, and they know it in my account, but only acknowledge Studio’s Clarity workflow as “purchased,” despite trying over and over to Validate (which they say is successful). I even tried on the computer I don’t use for this, thinking it might be something on my main computer, updating to 1.2.8, which is what the updater in the app automatically updated to for both computers, and both have Clarity (the other one I don’t use often didn’t, but now does). So it’s their end. Not the computer I’m using. Not whether or not I’m logged in.

I’ll need Topaz to once again make it so.

1 Like

Thanks for asking Scott. Yes, I am logged into my Topaz Studio Account. I have completed all the steps outlined in the Help article listed in my first post. I not only logged into Topaz Studio through the Community menu but I also went to the web site and logged in there thinking that might make the difference but no dice.

As you can see all my other Pro Adjustments are showing which would indicate the sync took place.

Looks like I’m now on 1.2.8; maybe when I did the uninstall and re-install.

Studio v1.1.9 cannot use the Impression Adjustment. Please update Studio to the latest version.

I did the update from 1.1.9 to version 1.2.8 first, then validated. All went well.

1 Like

@Kathy_9 Looks like Impression is between HSL Color Tuning and Motion Blurs.

AiDon

Did just update to 1.2.8 still Impression doesn’t appear. Topaz on Facebook said at first their server was overloaded, and not there may be a problem with the database.

What do you mean about problem with your database?

That is what I was told by Heath. Anyway, without any further actions on my part Impression suddenly appeared in the left hand menu and it appears all of the controls are there and work.

AiDon- suggest you communicate with your colleagues- fixing the problem was beyond anything I could do and the fix came from the Topaz people on Facebook.

I had the same problem with Impression. You can go back to your account and verified that Impression is listed Under My Products. Then go to Store and add Impression to the shopping cart. The price should show 0. Complete the order and you will get Impression in Studio work again.

Yes, I agree the whole thing is a mess. Topaz is in the process of moving Plug-ins to Studio. I think we will have to experience the same headache again.

1 Like

letitbe

Did verify my account first, added Impression to cart, got receipt- no luck. followed all directions for the update. As I said the Topaz people on Facebook found some corrupted user databases and fixed them, so all works now.
Nothing I could have done would have fixed the issue. Same happened with Clarity in Studio to many users.
Yes, whole Studio thing is still a mess and a headache, but if we want the updates we have to tolerate it I guess. Impression in Studio once it started working much faster than stand alone plugin- will have to explore other improvements- so I guess it was worth the trouble.