Importing doesn't work

We are experiencing an issue with Topaz. It doesn’t import videos anymore on one of two devices. We have it for two devices. We had it already installed on two computers, but for one we wanted to switch to another device. So we uninstalled it on one and installed it on the third device. Now, on the second device, on which Topaz remained, it’s unable to import video-files. Either dragging files or by clicking ‘browse’. Nothing happens after opening the file we want to use. We tried it with different video-formats

We have tried reinstalling, but it remains not working.

Does anyone know of this, why this happens and what to do about it? The device that has this issue is a macbook pro m1 max, 64gb memory. Also I should mention that it was working before the latest update 3.2.3

This is a known issue with the latest version of the app that our developers are currently working on patching. For now, you can follow these steps to restore app functionality:

  1. Uninstall Topaz Video AI
  2. Delete the app’s .plist files - How To Delete Your Plist Files
  3. Reboot your Mac
  4. Reinstall

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.