Images not opening in Topaz 3

When I invoke Topaz in Photoshop 2024, it launches and then stalls, i.e., the image doesn’t appear. I tried restarting my Mac and the problem remains.

I’ve also tried dragging an image file directly onto the stand-alone Topaz program and got the same result.

This problem has cropped up today and never before.

I have 2010 MacPro desktop computer using OpenCore to launch Ventura.

[Please describe your issue here. Try to include logs (Help → Logging) and add screenshots if necessary.]

Steps to reproduce issue:

  1. Attempt to invoke Topaz 3 in Photoshop
  2. Step 2
  3. Step 3

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Please follow the instructions below to perform a clean install to better troubleshoot why you had this problem with Topaz Photo AI:

First, please make sure that you have fully closed Photoshop before proceeding.

Start by clearing any previous plist files that are on your computer for Topaz Photo AI by following the steps in the link below:

Topaz Photo AI | plist Files Mac

After you have done this, disable any antivirus, firewall, VPN, or proxy software that might be active on your computer. These tools are sometimes known to interfere with the installer’s ability to download the model files.

Please also ensure that the Topaz Photo AI installer has all the proper settings in your system by going to your Mac System Settings > Privacy & Security tab and scrolling down to the security section. You will want to make sure you have 'App Store and identified developers ’ selected. Here is a video example:

Example of Proper System Preferences

Finally, rerun the installer. You can download a new installer from the downloads page directly :

Topaz Labs Download Page

Let me know how that goes for you and I’ll keep an eye out for your reply.