I don't get any preview of the modifications

I’ve just updated Photo AI, but it doesn’t work for me :
I don’t get any preview of the modifications. Only the original image.

Steps to reproduce issue:

1.I opened a raw picture made by the Sony A7R3 (42MB)
2. I let everything in Autopilot didn’t change any setting.
3. I had the split view enabled. On the lower left corner a progress indicated the preview was updated, but then only a blank appeared in the right part of the window instead of the preview.
4. I tried to save the picture, but got only a blank picture.
I checked to see whether i was logged on, the command said “logout”… so I assume that I was logged on.

Topaz Photo AI [v1.x.x] on [Windows/Mac]

Hey there! Can you upload your original RAW image to this thread for us to test?

Thanks :slight_smile:

_20230405_001.arw (41.3 MB)

Here you go with my raw picture. May be one problem is that my most used editor is Lightroom and the picture was already loaded in Lightroom before ?
I tried to upload the blank picture Photo AI produced and saved, but the size seems to be to big. I will try to send it separately in a next message.

By the way, I’m using a Window 11 64bit computer and everything is updated.

The saved blank picture is a dng named _20230405_001-topaz-denoiseraw-sharpen and weight 241 MB
I uploaded it on my MS Drive; here is a link to it :Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.
Thanks for taking care of the bug, or telling me what I did wrong.

I don’t think the link worked here is a new try : Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.
May be it worked after all…

I just saw there was a new update as of today. I downloaded it and tested to see whether the problem had gone away, but it is still there.
It is there whether I load the picture starting from the Lightroom catalogue or whether I load it directly into Photo AI.

OK I found the problem : Lightroom adds something to the raw when they are catalogued. Feeding the raw directly into Topaz AI results in problems. Same with using the Edit in command.

However, when you use the command Plugin Extras in LR, then a dialogue box popup asking you whether you want to overwrite the file; if you answer yes, then Photo AI works as intended.

False good new : I wasn’t able to repeat that. Now the little dialogue box won’t show anymore and I’m getting the same blank window and blank files as before.

Thanks for the info @rrr_hhh, we’ll look into this and have a full response shortly!

1 Like

I think that I have found the problem :slight_smile:

I changed the preferences for the AI processor from Auto to CPU. I came to that idea after a cropped picture with few details went through correctly.

Once the AI processor preference was changed, all kinds of pictures, however big or detailed, could be treated correctly. I should have thought to that because I already had that problem with Sharpen AI. But then the program becomes so slow that it’s almost unusable in everyday work.

In case that is of interest for you, you’ll find infos on my system and on the graphic card in the enclosed file.

Computer and NVIDIA System Information 04-18-2023 19-54-49.txt (4.8 KB)


By the way the program did quite a good job… Too bad it is so slow when only the CPU processor is used.