How to select GPU to use by Gigapixel AI?

My laptop has two GPU:

  1. Integrated AMD Vega 8
  2. AMD Radeon RX 560X

The problem is Gigapixel API always uses the first GPU (Vega 8) which is slower.
Also “Graphics Info” shows that Vega 8 is the one that is detected:

Graphics Hardware: AMD Radeon(TM) Vega 8 Graphics
OpenGL Driver: 3.3.13587 Core Profile Forward-Compatible Context 20.4.2 26.20.15029.27016

How do you set Gigapixel AI to define which GPU to use, or at least use the best GPU when working with image processing?

Type graphics in the Windows search box (lower left corner) and Choose Graphics settings. Browse for the program you want to use the RX560 and add it to the list. Click on the program in the list and choose options > high Performance. See below:

1 Like

Hello I already did this but somehow, Gigapixel still uses the slower GPU despite selecting high performance.

For the community, the solution that worked (at least in my case) is to go to Control Panel and open “Power Options” then navigate to find the “Switchable Dynamic Graphics” menu item then select Global Settings then set “Maximum Performance” for either “On Battery” mode or “Plugged in” mode which ever you prefer to use the desired GPU.