How do I stop Gigapixel from removing analog grain?

I have an analog looking image, lofi-ish, very grainy and I want it to stay that way. However Gigapixel keeps removing the grain, when I try to upscale it. I tried different AI models, set Suppress Noise, Remove Blur and Fix Compression all to 0, it still removes all the grain. How do I stop it from doing that?

I might have figured it out, using ‘Lines’ mode with Suppress Noise on 0 gives pretty good results.

1 Like

HiFi model with no parameters is the best at not smoothing out grain, it instead realistically maps to higher rez natural grain if it belongs to the texture (but not overall image quality grain that will probably get smoothed). Beware though Hifi in Gigapixel adds color noise, this is fixed in Photo AI.

I just tried it out, but there is still a lot of grain smoothed out. Had better results with ‘Lines’. Or am I missing some additional setting? I got all I can see turned off / set to 0

We trained the upscaling models on digital images for upscaling. It’s not trained to keep analog grain so it may not work great for that use case.

I would expect that decreasing suppress noise to 0 should prevent the application from removing this grain. Aside from that, it sounds like you found the best model for this.