How do I request a refund?

There’s supposed to be an unconditional 30-day refund policy. Gigapixel is too unreliable. It often processes just a few images in a folder and then stops until I manually restart it. Even when it works, the output is also not useful to me. I want a refund.

The “Contact Us” link goes to a dead Zendesk account. The Help Center link also goes to a dead Zendesk account. The support site has a “refund” topic, which - guess what - also links to a dead Zendesk account.

I want a refund and will be forced to request a chargeback if I can’t get one properly. VEAI works well and I want to keep it, but Gigapixel is totally useless to me.

Thank you.

1 Like

I don’t see what you see, but in the Help Center on the RH side is a contact form:

image

If you can’t see it click on the icon …

image

help@topazlabs.com seems to be working as I got an auto-reply. Perhaps there was a glitch when you tried?

-------- Forwarded Message --------
Subject: 	Re: Test support address - ignore
Date: 	Thu, 01 Dec 2022 08:23:38 +0000
From: 	Topaz Labs Support <help@topazlabs.com>

*We are experiencing support delays as we assist more customers than normal during our Black Friday sale. *If you cannot complete your purchase before the end of sale, don't worry! We are leaving the pricing the same on our website for several more days while we help everyone who still needs assistance.

*Thank you for your patience as we work to respond to everyone as soon as possible.
*

PS Something about the 30-day free trial didn’t appeal to you?

Topaz-Labs is very flexible about refunds so I don’t think that will be necessary. We just need to find out why your emails are not going through.

Experienced exactly the same issue. Click on the links for “contact” and it takes you down a dead end.
If you go into your account you can make contact thru there. I sent a message yesterday and have had no response yet.
Let us know how you get on with the refund…again I’m experiencing similar issues

I don’t see that on the Support site only that the “Ask” option is not available out of working hours. If you need to contact click on Email and you get this panel:
image

Fill in Subject, Address and Details then you will get an email confirmation that it has been received.

RE contact-us: I just sent a test message and got an auto-reply within 1-2 mins.

RE response-time: The contact-us indicates a heavier than normal traffic flow of tickets.

image_2022-12-01_120816316

When reporting, a screen-shot of the problem is always helpful to see what’s going on. “Dead end” is not very informative as to root cause, particularly when the link appears to be working as designed for some users. It’s possible that hiccups are occurring due to high server load which are intermittent and therefore tough to PD. Many CRM’s are hosted by third-party platforms which adds another layer to trouble-shoot.

1 Like

Thanks but don’t worry about it, the op has not even returned to see or read any response. I suspect they have either received a response from support or they were just venting.

Thank you for your help.